Link Visio Shapes to Kintone Data

Ready to get started?

Download a free trial of the Kintone ODBC Driver to get started:

 Download Now

Learn more:

Kintone  Icon Kintone ODBC Driver

The Kintone ODBC Driver is a powerful tool that allows you to connect with live Kintone applications, directly from any applications that support ODBC connectivity.

Access Kintone applications and databases from virtually anywhere through a standard ODBC Driver interface.



Automatically update Kintone data with the changes you make to Visio master shapes.

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Kintone. The driver surfaces Kintone data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Kintone data.

Connect to Kintone as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

In addition to the authentication values, set the following parameters to connect to and retrieve data from Kintone:

  • Url: The URL of your account.
  • GuestSpaceId: Optional. Set this when using a guest space.

Authenticating with Kintone

Kintone supports the following authentication methods.

Using Password Authentication

You must set the following to authenticate:

  • User: The username of your account.
  • Password: The password of your account.

Using Basic Authentication

If the basic authentication security feature is set on the domain, supply the additional login credentials with BasicAuthUser and BasicAuthPassword. Basic authentication requires these credentials in addition to User and Password.

Using Client SSL

Instead of basic authentication, you can specify a client certificate to authenticate. Set SSLClientCert, SSLClientCertType, SSLClientCertSubject, and SSLClientCertPassword. Additionally, set User and Password to your login credentials.

Connect Kintone Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Kintone, select the table you want to import, and finish the wizard. This article uses Comments as an example.

Link Kintone Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Kintone entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Comments as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Kintone entities onto the drawing page and add association lines back to the main topic, Comments. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Comments entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Kintone data.