Link Visio Shapes to Pinterest Data

Ready to get started?

Download for a free trial:

Download Now

Learn more:

Pinterest ODBC Driver

The Pinterest ODBC Driver is a powerful tool that allows you to connect with live data from Pinterest, directly from any applications that support ODBC connectivity.

Access Pinterest data like you would a database - read, write, and update Pinterest Boards, Followers, Pins, etc. through a standard ODBC Driver interface.



Automatically update Pinterest data with the changes you make to Visio master shapes.

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Pinterest. The driver surfaces Pinterest data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Pinterest data.

Connect to Pinterest as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Pinterest authentication is based on the standard OAuth flow. To authenticate, you must initially create an app via the Pinterest developer platform where you can obtain an OAuthClientId, OAuthClientSecret, and CallbackURL.

Set InitiateOAuth to GETANDREFRESH and set OAuthClientId, OAuthClientSecret, and CallbackURL based on the property values for the app you created.

See the Help documentation for other OAuth authentication flows.

Connect Pinterest Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Pinterest, select the table you want to import, and finish the wizard. This article uses Users as an example.

Link Pinterest Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Pinterest entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Users as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Pinterest entities onto the drawing page and add association lines back to the main topic, Users. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Users entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Pinterest data.