Author and Share Power BI Reports on Real-Time Presto Data

Ready to get started?

Download for a free trial:

Download Now

Learn more:

Presto ODBC Driver

The Presto ODBC Driver is a powerful tool that allows you to connect with live data from Presto, directly from any applications that support ODBC connectivity.

Access Presto data like you would a database - read, write, and update Presto Tables, etc. through a standard ODBC Driver interface.



Use the CData ODBC Driver for Presto to visualize Presto data in Power BI Desktop and then upload to the Power BI service.

With built-in support for ODBC on Microsoft Windows, CData ODBC Drivers provide self-service integration with self-service analytics tools such as Microsoft Power BI. The CData ODBC Driver for Presto links your Power BI reports to operational Presto data. You can monitor Presto data through dashboards and ensure that your analysis reflects Presto data in real time by scheduling refreshes or refreshing on demand. This article details how to use the ODBC driver to create real-time visualizations of Presto data in Microsoft Power BI Desktop and then upload to Power BI.

The CData ODBC Drivers offer unmatched performance for interacting with live Presto data in Power BI due to optimized data processing built into the driver. When you issue complex SQL queries from Power BI to Presto, the driver pushes supported SQL operations, like filters and aggregations, directly to Presto and utilizes the embedded SQL Engine to process unsupported operations (often SQL functions and JOIN operations) client-side. With built-in dynamic metadata querying, you can visualize and analyze Presto data using native Power BI data types.

Connect to Presto as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Set the Server and Port connection properties to connect, in addition to any authentication properties that may be required.

To enable TLS/SSL, set UseSSL to true.

Authenticating with LDAP

In order to authenticate with LDAP, set the following connection properties:

  • AuthScheme: Set this to LDAP.
  • User: The username being authenticated with in LDAP.
  • Password: The password associated with the User you are authenticating against LDAP with.

Authenticating with Kerberos

In order to authenticate with KERBEROS, set the following connection properties:

  • AuthScheme: Set this to KERBEROS.
  • KerberosKDC: The Kerberos Key Distribution Center (KDC) service used to authenticate the user.
  • KerberosRealm: The Kerberos Realm used to authenticate the user with.
  • KerberosSPN: The Service Principal Name for the Kerberos Domain Controller.
  • KerberosKeytabFile: The Keytab file containing your pairs of Kerberos principals and encrypted keys.
  • User: The user who is authenticating to Kerberos.
  • Password: The password used to authenticate to Kerberos.

After creating a DSN, follow the steps below to connect to the Presto DSN from Power BI Desktop:

  1. Open Power BI Desktop and click Get Data -> ODBC. To start Power BI Desktop from PowerBI.com, click the download button and then click Power BI Desktop.
  2. Select the DSN in the menu. If you know the SQL query you want to use to import, expand the Advanced Options node and enter the query in the SQL Statement box.
  3. Select tables in the Navigator dialog.
  4. Click Edit to edit the query. The table you imported is displayed in the Query Editor. In the Query Editor, you can enrich your local copy of Presto data with other data sources, pivot Presto columns, and more. Power BI detects each column's data type from the Presto metadata retrieved by the driver.

    Power BI records your modifications to the query in the Applied Steps section, adjusting the underlying data retrieval query that is executed to the remote Presto data. When you click Close and Apply, Power BI executes the data retrieval query.

    Otherwise, click Load to pull the data into Power BI.

Create Data Visualizations

After pulling the data into Power BI, you can create data visualizations in the Report view by dragging fields from the Fields pane onto the canvas. Follow the steps below to create a pie chart:

  1. Select the pie chart icon in the Visualizations pane.
  2. Select a dimension in the Fields pane: for example, FirstName.
  3. Select a measure in the LastName in the Fields pane: for example, LastName.

You can change sort options by clicking the ellipsis (...) button for the chart. Options to select the sort column and change the sort order are displayed.

You can use both highlighting and filtering to focus on data. Filtering removes unfocused data from visualizations; highlighting dims unfocused data. You can highlight fields by clicking them:

You can apply filters at the page level, at the report level, or to a single visualization by dragging fields onto the Filters pane. To filter on the field's value, select one of the values that are displayed in the Filters pane.

Click Refresh to synchronize your report with any changes to the data.

Upload Presto Data Reports to Power BI

You can share reports based on ODBC data sources with other Power BI users in your organization. To upload a dashboard or report, log into PowerBI.com, click Get Data -> Files, and navigate to a Power BI Desktop file or Excel workbook. You can then select the report in the Reports section.

Refresh on Schedule and on Demand

You can use the Power BI Personal Gateway to automatically refresh the dataset associated with your report. You can also refresh the dataset on demand in Power BI. After installing the Personal Gateway, follow the steps below to schedule refreshes for an ODBC DSN:

  1. Log into Power BI.
  2. In the Dataset section, right-click the Presto Dataset.
  3. Click Schedule Refresh.
  4. In the settings for your dataset, expand the Data Source Credentials node and click Edit Credentials in the ODBC section.
  5. Expand the Schedule Refresh section, select Yes in the Keep Your Data Up to Date menu, and specify the refresh interval.

You can now share real-time Presto reports through Power BI.