Ready to get started?

Learn more about Sage US Connectivity Solutions

Learn More

Design BIRT Reports on Sage US Data

Provide current Sage US data to your embedded analytics.

The CData JDBC Driver for Sage US integrates connectivity to Sage US APIs into your data-driven Java applications. You can use the CData JDBC Driver for Sage US with the BIRT (Business Intelligence Reporting Tools) platform to create BIRT reports that reflect changes to your data in real time.

  1. If you have not already done so, install the BIRT Framework plugin and the Database Development plugin for Eclipse.
  2. Click File -> New -> Report. The Report Design perspective is opened.
  3. In the Data Explorer, right-click Data Sources and click New Data Source.
  4. Select the Create from a Data Source Type in the Following List option and select JDBC Data Source.
  5. Click Manage Drivers and add the driver JAR, located in the lib subfolder of the installation folder.
  6. In the Database URL box, enter the JDBC URL containing the connection string.

    The Application Id and Company Name connection string options are required to connect to Sage as a data source. You can obtain an Application Id by contacting Sage directly to request access to the Sage 50 SDK.

    Sage must be installed on the machine. The Sage.Peachtree.API.dll and Sage.Peachtree.API.Resolver.dll assemblies are required. These assemblies are installed with Sage in C:\Program Files\Sage\Peachtree\API\. Additionally, the Sage SDK requires .NET Framework 4.0 and is only compatible with 32-bit applications. To use the Sage SDK in Visual Studio, set the Platform Target property to "x86" in Project -> Properties -> Build.

    You must authorize the application to access company data: To authorize your application to access Sage, restart the Sage application, open the company you want to access, and connect with your application. You will then be prompted to set access permissions for the application in the resulting dialog.

    While the compiled executable will require authorization only once, during development you may need to follow this process to reauthorize a new build. To avoid restarting the Sage application when developing with Visual Studio, click Build -> Configuration Manager and uncheck "Build" for your project.

    Built-in Connection String Designer

    For assistance in constructing the JDBC URL, use the connection string designer built into the Sage US JDBC Driver. Either double-click the JAR file or execute the jar file from the command-line.

    java -jar cdata.jdbc.sage50us.jar

    Fill in the connection properties and copy the connection string to the clipboard.

    When you configure the JDBC URL, you may also want to set the Max Rows connection property. This will limit the number of rows returned, which is especially helpful for improving performance when designing reports and visualizations.

    A typical JDBC URL is below:

    jdbc:sage50us:ApplicationId=8dfafu4V4ODmh1fM0xx;CompanyName=Bellwether Garden Supply - Premium;
  7. Right-click the Data Sets folder and select the JDBC data source for Sage US.
  8. In the resulting dialog, build the SELECT query to be used to retrieve the data for the report. This article uses the following query: SELECT Name, LastInvoiceAmount FROM Customer
  9. In the Palette, drag a Chart onto the editor. The chart wizard is displayed.
  10. After selecting the chart type, drag columns onto the chart fields on the Select Data tab.
  11. Click Run -> View Report -> In Web Viewer to view the report.

Your BIRT reports can now pick up any updates to Sage US data.

To publish the report to your application server, add the driver JAR to the BIRT Viewer's classpath. For more information, see the CData KB for guides to deploying the JDBC Driver on Java application servers.