Ready to get started?

Learn more about the or download a free trial:

Download Now

Integrate Sage US Data in the Pentaho Report Designer

Publish reports based on Sage US data in the Pentaho BI tool.

The CData JDBC Driver for Sage US data enables access to live data from dashboards and reports. This article shows how to connect to Sage US data as a JDBC data source and publish reports based on Sage US data in Pentaho.

Connect and Create a Report

  1. Copy the JAR file of the driver, located in the lib subfolder of the installation directory, to the \Report-Designer\lib\jdbc\ folder in the Pentaho directory.
  2. Run the report-designer.bat file in the \Report-Designer\ folder to open the Report-Designer UI.
  3. Create a new data source with the driver by clicking Data -> Add Data Source -> Advanced -> JDBC (Custom) and then creating a new Sage US connection. In the resulting dialog, configure the connection properties as shown below.

    • Custom Connection URL property: Enter the JDBC URL. This starts with jdbc:sage50us: and is followed by a semicolon-separated list of connection properties.

      The Application Id and Company Name connection string options are required to connect to Sage as a data source. You can obtain an Application Id by contacting Sage directly to request access to the Sage 50 SDK.

      Sage must be installed on the machine. The Sage.Peachtree.API.dll and Sage.Peachtree.API.Resolver.dll assemblies are required. These assemblies are installed with Sage in C:\Program Files\Sage\Peachtree\API\. Additionally, the Sage SDK requires .NET Framework 4.0 and is only compatible with 32-bit applications. To use the Sage SDK in Visual Studio, set the Platform Target property to "x86" in Project -> Properties -> Build.

      You must authorize the application to access company data: To authorize your application to access Sage, restart the Sage application, open the company you want to access, and connect with your application. You will then be prompted to set access permissions for the application in the resulting dialog.

      While the compiled executable will require authorization only once, during development you may need to follow this process to reauthorize a new build. To avoid restarting the Sage application when developing with Visual Studio, click Build -> Configuration Manager and uncheck "Build" for your project.

      Built-in Connection String Designer

      For assistance in constructing the JDBC URL, use the connection string designer built into the Sage US JDBC Driver. Either double-click the JAR file or execute the jar file from the command-line.

      java -jar cdata.jdbc.sage50us.jar

      Fill in the connection properties and copy the connection string to the clipboard.

      When you configure the JDBC URL, you may also want to set the Max Rows connection property. This will limit the number of rows returned, which is especially helpful for improving performance when designing reports and visualizations.

      Below is a typical JDBC URL:

      jdbc:sage50us:ApplicationId=8dfafu4V4ODmh1fM0xx;CompanyName=Bellwether Garden Supply - Premium;
    • Custom Driver Class Name: Enter cdata.jdbc.sage50us.Sage50USDriver.
    • User Name: The username to authenticate with.
    • Password: The password to authenticate with.

Add Sage US Data to a Report

You are now ready to create a report with Sage US data.

  1. Add the Sage US source to your report: Click Data -> Add Data Source -> JDBC and select the data source.

  2. Configure the query. This article uses the one below:

    SELECT Name, LastInvoiceAmount FROM Customer
  3. Drag a chart onto your report and double-click it to edit the chart. Run the report to display the chart. You can use the results of this query to create a simple chart for the Customer table.
  4. Finally, run the report to see the chart.