Ready to get started?

Learn more about the CData ODBC Driver for Salesforce or download a free trial:

Download Now

Link Visio Shapes to Salesforce Data

Automatically update Salesforce data with the changes you make to Visio master shapes.

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Salesforce. The driver surfaces Salesforce data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Salesforce data.

Connect to Salesforce as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

There are several authentication methods available for connecting to Salesforce: Login, OAuth, and SSO. The Login method requires you to have the username, password, and security token of the user.

If you do not have access to the username and password or do not wish to require them, you can use OAuth authentication.

SSO (single sign-on) can be used by setting the SSOProperties, SSOLoginUrl, and TokenUrl connection properties, which allow you to authenticate to an identity provider. See the "Getting Started" chapter in the help documentation for more information.

Connect Salesforce Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Salesforce, select the table you want to import, and finish the wizard. This article uses Account as an example.

Link Salesforce Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Salesforce entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Account as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Salesforce entities onto the drawing page and add association lines back to the main topic, Account. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Account entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Salesforce data.