Ready to get started?

Learn more about the CData ODBC Driver for SAP Fieldglass or download a free trial:

Download Now

Link Visio Shapes to SAP Fieldglass Data

Automatically update SAP Fieldglass data with the changes you make to Visio master shapes.

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for SAP Fieldglass. The driver surfaces SAP Fieldglass data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to SAP Fieldglass data.

Connect to SAP Fieldglass as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

To authenticate, you will need to specify the Username, Password, APIKey, and EnvironmentURL connection properties.

To obtain an APIKey, log in to the SAP API Business Hub and click on Get API Key.

Connect SAP Fieldglass Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for SAP Fieldglass, select the table you want to import, and finish the wizard. This article uses AuditTrails as an example.

Link SAP Fieldglass Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link SAP Fieldglass entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter AuditTrails as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other SAP Fieldglass entities onto the drawing page and add association lines back to the main topic, AuditTrails. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other AuditTrails entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external SAP Fieldglass data.