Link Visio Shapes to SFTP Data

Ready to get started?

Download for a free trial:

Download Now

Learn more:

SFTP ODBC Driver

The SFTP ODBC Driver is a powerful tool that allows you to connect with live data from remote files and directories, directly from any applications that support ODBC connectivity.

Access remote data like you would a database through a standard ODBC Driver interface.



Automatically update SFTP data with the changes you make to Visio master shapes.

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for SFTP. The driver surfaces SFTP data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to SFTP data.

Connect to SFTP as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

SFTP can be used to transfer files to and from SFTP servers using the SFTP Protocol. To connect, specify the RemoteHost;. service uses the User and Password and public key authentication (SSHClientCert). Choose an SSHAuthMode and specify connection values based on your selection.

Set the following connection properties to control the relational view of the file system:

  • RemotePath: Set this to the current working directory.
  • TableDepth: Set this to control the depth of subfolders to report as views.
  • FileRetrievalDepth: Set this to retrieve files recursively and list them in the Root table.
Stored Procedures are available to download files, upload files, and send protocol commands. See gdatamodel for more on using SQL to interact with the server.

Connect SFTP Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for SFTP, select the table you want to import, and finish the wizard. This article uses MyDirectory as an example.

Link SFTP Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link SFTP entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter MyDirectory as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other SFTP entities onto the drawing page and add association lines back to the main topic, MyDirectory. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other MyDirectory entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external SFTP data.