Visio Shapes とFTP Data を連携

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

FTP ODBC Driver

FTP ODBC Driver は、ODBC 接続をサポートするさまざまなアプリケーションからSalesforce リモートファイルやディレクトリのリアルタイムデータ連携を実現するパワフルなツールです。

標準ODBC ドライバーインターフェースを通じて、データベースにアクセスするのと同じ感覚でリモートデータにアクセス。



Visio master shapes での変更を自動的にFTP data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for FTP. The driver surfaces FTP data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to FTP data.

Connect to FTP as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

FTP は、プレーンテキスト接続およびSSL/TLS 接続の両方をサポートします。FTP サーバーに接続するには、RemoteHost、User、およびPassword を指定します。SSLMode およびSSLServerCert を設定して、TSL/SSL による接続をセキュアにします。TLS/SSL を介した接続の設定について詳しくは、ヘルプドキュメントの「高度な設定」を参照してください。

次の接続プロパティを設定し、ファイルシステムのリレーショナルビューをコントロールします。

  • RemotePath:現在の作業ディレクトリに設定。
  • TableDepth:ビューとしてレポートするサブフォルダの深度を制御するために設定。
  • FileRetrievalDepth:ファイルを再帰的に取得し、Root テーブルにリストするために設定。

ストアドプロシージャ は、ファイル、のダウンロード、アップロード、およびプロトコルコマンドの送信に利用できます。 SQL を使用してサーバーと対話する方法の詳細については、ヘルプドキュメントの「データモデル」を参照してください。

Connect FTP Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for FTP, select the table you want to import, and finish the wizard. This article uses MyDirectory as an example.

Link FTP Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link FTP entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter MyDirectory as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other FTP entities onto the drawing page and add association lines back to the main topic, MyDirectory. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other MyDirectory entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external FTP data.