Visio Shapes とAsana Data を連携

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

Asana ODBC Driver

Asana ODBC Driver を使って、ODBC 接続をサポートするあらゆるアプリケーション・ツールからAsana にデータ連携。

Asana データにデータベースと同感覚でアクセスして、Asana のProject、Tasks、Teams、Users データに使い慣れたODBC インターフェースで双方向連携。



Visio master shapes での変更を自動的にAsana data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Asana. The driver surfaces Asana data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Asana data.

Connect to Asana as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Asana への接続は以下のように行います。

  • WorkspaceId: Asana Wrokspace のglobally unique identifier (gid) を設定すると指定されたWorkspace のプロジェクトだけを返します。Workspace Id はhttps://app.asana.com/api/1.0/workspaces から取得します。表示されるJSON にWorkspace name およびId が含まれます。
  • ProjectId: Asana Project のglobally unique identifier (gid) に設定すると指定されたProject のデータだけを返します。Project ID はプロジェクトのOverview ページのURL を参照してください。/0/ の後ろの数字 です。

OAuth 認証

Asana への認証にはOAuth 認証が使われます。OAuth はAsana のブラウザで認証ユーザーを認証する処理が必要です。OAuth の詳細については、ヘルプドキュメントの「はじめに」を参照してください。

Connect Asana Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Asana, select the table you want to import, and finish the wizard. This article uses projects as an example.

Link Asana Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Asana entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter projects as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Asana entities onto the drawing page and add association lines back to the main topic, projects. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other projects entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Asana data.