Visio Shapes とIBM Informix Data を連携

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

IBM Informix ODBC Driver

IBM Informix ODBC Driver を使って、ODBC 接続をサポートするあらゆるアプリケーション・ツールからIBM Informix にデータ連携。

IBM Informix データにデータベースと同感覚でアクセスして、IBM Informix データベースに使い慣れたODBC インターフェースで双方向連携。



Visio master shapes での変更を自動的にIBM Informix data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for IBM Informix. The driver surfaces IBM Informix data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to IBM Informix data.

Connect to IBM Informix as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

以下のプロパティを設定してIBM Informix に接続します。

  • Server:IBM Informix を実行しているサーバーの名前に設定。
  • Port:IBM Informix サーバーがリッスンしているポートに設定。
  • Database:IBM Informix データベースの名前に設定。
  • User:データベースへのアクセスを許可されたユーザーのユーザー名に設定。
  • Password:データベースへのアクセスを許可されたユーザーのパスワードに設定。

Connect IBM Informix Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for IBM Informix, select the table you want to import, and finish the wizard. This article uses Books as an example.

Link IBM Informix Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link IBM Informix entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Books as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other IBM Informix entities onto the drawing page and add association lines back to the main topic, Books. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Books entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external IBM Informix data.