Visio Shapes とOneNote Data を連携

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

OneNote ODBC Driver

OneNote ODBC Driver を使って、ODBC 接続をサポートするあらゆるアプリケーション・ツールからMicrosoft OneNote データに連携。

OneNote にデータベースのようにアクセス -Notebooks、Notes、Searches、TagsにODBC インターフェースで接続。



Visio master shapes での変更を自動的にOneNote data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for OneNote. The driver surfaces OneNote data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to OneNote data.

Connect to OneNote as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

OneNote は、Oauth 認証標準を使います。事前にアプリを作成し、OAuthClientId、OAuthClientSecret、CallbackURLuses の値を取得します。詳細はヘルプドキュメントを参照してください。

Connect OneNote Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for OneNote, select the table you want to import, and finish the wizard. This article uses Notebooks as an example.

Link OneNote Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link OneNote entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Notebooks as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other OneNote entities onto the drawing page and add association lines back to the main topic, Notebooks. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Notebooks entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external OneNote data.