Visio Shapes とPCA Accounting Data を連携

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

PCA Accounting ODBC Driver

PCA クラウド会計 ODBC ドライバーは、ODBC 接続をサポートする任意のアプリケーション からライブなPCA クラウド会計データに直接接続できる強力なツールです。標準のODBC ドライバー インタフェースを使用して、データベースのようにPCA クラウド会計にアクセスし、顧客、商品、伝票などの読み出し、書き込み、および更新を実行できます。



Visio master shapes での変更を自動的にPCA Accounting data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for PCA Accounting. The driver surfaces PCA Accounting data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to PCA Accounting data.

Connect to PCA Accounting as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

PCA クラウド会計DX では、OAuth 2 認証標準を使います。

ユーザー資格情報の接続プロパティを設定せずに接続できます。接続に最小限必要な接続プロパティは、次のとおりです。

  • InitiateOAuth:GETANDREFRESH に設定。InitiateOAuth を使って、OAuth 交換や、手動での接続文字列のアクセストークン設定の繰り返しを避けられます。
  • OAuthClientId:アプリケーション設定のクライアントId に設定。
  • OAuthClientSecret:アプリケーション設定のクライアントシークレットに設定。
  • CallbackURL:アプリケーション設定のリダイレクトURL に設定。
  • ApiVersion:接続するPCA API Server バージョンを設定。
  • DefaultDataArea:接続するデータ領域を設定。
  • DataCenter:接続するサーバーのDataCenter 名を設定。
  • ProductCode:PCA 製品コード名を設定。
  • InputModuleName:PCA InputSlip のInputModuleName を設定。

接続すると、本製品はデフォルトブラウザでPCA Accounting OAuth エンドポイントを開きます。ログインして、本製品にアクセス許可を与えます。本製品がOAuth プロセスを完了します。

ヘッドレスマシンの認証など、他のOAuth 認証フローについては、ヘルプドキュメントの「OAuth 認証の使用」を参照してください。

Connect PCA Accounting Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for PCA Accounting, select the table you want to import, and finish the wizard. This article uses BuGroup as an example.

Link PCA Accounting Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link PCA Accounting entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter BuGroup as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other PCA Accounting entities onto the drawing page and add association lines back to the main topic, BuGroup. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other BuGroup entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external PCA Accounting data.