Visio Shapes とSybase Data を連携

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

Sybase ODBC Driver

Sybase ODBC Driver で、ODBC 接続をサポートするあらゆるツール・アプリケーションからSybase データベースに連携が可能になります。

標準ODBC Driver インターフェースでSybase データベースをを仮想化してどこからでもアクセス可能に。



Visio master shapes での変更を自動的にSybase data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Sybase. The driver surfaces Sybase data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Sybase data.

Connect to Sybase as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Sybase は、Basic 認証、Kerberos 認証、LDAP 認証などの認証方法をいくつかサポートしています。

Basic 認証を使用した接続

次を設定してデータを認証し接続します。User およびPassword を設定してSybaseIQ 認証を使用します。

  • User:認証Sybase ユーザーのユーザー名に設定。
  • Password:認証Sybase ユーザーのパスワードに設定。
  • Server:SybaseIQ またはSAP SQL Anywhere データベースインスタンスの名前またはネットワークアドレスに設定。
  • Database:指定されたサーバーで実行されているSybaseIQ またはSAP SQL Anywhere データベースの名前に設定。

オプションで、UseSSL をtrue に設定することにより、TLS/SSL で接続を保護できます。

Note: 上記の本製品 設定でSAP SQL Anywhere のインスタンスに接続することもできます。

Kerberos 認証を使用した接続

Kerberos 認証を活用するには、次の接続プロパティを使用してそれを有効にすることから始めます。

  • AuthScheme:Kerberos に設定すると、Sybase への認証に使用されます。

Kerberos 認証用に設定する必要がある接続プロパティに関しては、Kerberos の使用 情報を参照してください。

以下は接続文字列の例です。

Server=MyServer;Port=MyPort;User=SampleUser;Password=SamplePassword;Database=MyDB;Kerberos=true;KerberosKDC=MyKDC;KerberosRealm=MYREALM.COM;KerberosSPN=server-name

LDAP 認証を使用した接続

LDAP 認証で接続するには、LDAP 認証メカニズムを使用するようにSybase サーバーサイドを設定する必要があります。

LDAP 用にSybase を設定したら、Basic 認証と同じクレデンシャルを使用して接続できます。

Connect Sybase Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Sybase, select the table you want to import, and finish the wizard. This article uses Products as an example.

Link Sybase Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Sybase entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Products as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Sybase entities onto the drawing page and add association lines back to the main topic, Products. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Products entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Sybase data.