Power View でのAct CRM データのインポートとビジュアライズ

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

Act CRM ODBC Driver

Act CRM ODBC Driver は、ODBC 接続をサポートするさまざまなアプリケーションからAct CRM への接続を実現するパワフルなツールです。

標準のODBC ドライバーインターフェースを使用して、データベースのようにAct CRM データにアクセスし、Companies、Contact、Groups、Opportunities などの読み、書き、更新を実行できます。



Excel でAct CRM データを使ったデータビジュアライゼーションを作成します。

Excel に組み込まれているODBC サポートを使用して、Act CRM データを使用したPower View レポートを素早く作成できます。この記事では、Data リボンからアクセスできるData Connection Wizard を使用して、Act CRM をPower View レポートにインポートする方法を説明します。

ODBC Data Source としてAct CRM に接続

未指定の場合は、初めにODBC DSN (data source name) で接続プロパティを指定します。ドライバーのインストールの最後にアドミニストレーターが開きます。Microsoft ODBC Data Source Administrator を使用して、ODBC DSN を作成および構成できます。

Authentication セクションのUserPassword プロパティに、有効なAct! ユーザー資格情報を設定する必要があります。認証値に加えて、以下も参照してください。

  • Act! Premium への接続

    認証値に加えて、Act! へのURL も設定が必要です。例:https://eup1-iis-04.eu.hosted.act.com/。

    さらに、接続するActDatabase を指定する必要があります。これは、ご自分のアカウントの「About Act! Premium」メニューのページ右上にある「?」で確認することができます。表示されたウィンドウの「Database Name」を使用します。

  • Act! Premium Cloud への接続

    Act! Premium Cloud アカウントに接続するには、ActCloudName プロパティも指定する必要があります。このプロパティはCloud アカウントのURL アドレスで確認できます。例:https://eup1-iis-04.eu.hosted.act.com/ActCloudName/。

ActCRM メタデータの取得は高負荷になる可能性があることに注意してください。CacheMetadata プロパティを設定して、メタデータをローカルに格納することをお勧めします。

DSN を構成する際に、Max Rows プロパティを定めることも可能です。これによって返される行数が制限されるので、ビジュアライゼーション・レポートのデザイン時のパフォーマンスを向上させるのに役立ちます。

Data Connection Wizard で接続

以下のステップに従って、Excel のData Connection Wizard からDSN に接続します。

  1. [Data]タブで、[From Other Sources]->[From Data Connection Wizard]とクリックします。
  2. [Data Connection Wizard]で[ODBC DSN]オプションを選択します。
  3. リストから[ODBC DSN for Act CRM]を選択します。
  4. 操作するテーブルを選択します。

    複数のテーブルをインポートする場合は、[Connect to a specific table]オプションの選択を解除します。データソースに接続したら、複数のテーブルを選択できます。[Finish]をクリックして[Data Connection Wizard]を閉じた後、[Select Table]ダイアログで[Enable selection of multiple tables]オプションを選択します。

  5. [Import Data]ダイアログで、データのインポート先を選択します。例えば、[Table]オプションと[Existing worksheet]オプションを選択します。次に、結果を出力するワークシートのセルをクリックします。
  6. [Insert]->[Power View]とクリックして新しいPower View レポートを作成します。

テーブルの作成

テーブルは、チャートやその他のデータの表現の開始点です。テーブルを作成するには、フィールドリストでカラムを選択します。テーブル名とカラム名をビューにドラッグアンドドロップすることも可能です。

データのビジュアライゼーションを作成

[Design]タブで、テーブルをチャートやその他のビジュアライゼーションに変更できます。