Tibco Spotfire から、ODBC 経由でAzure Analysis Services データに連携してビジュアライズ

製品をチェック

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

Azure Analysis Services ODBC Driver

Azure Analysis Services ODBC Driver を使って、ODBC 接続をサポートするあらゆるアプリケーション・ツールからデータ連携。

Azure Analysis Services にデータベースと同感覚でアクセスして、使い慣れたODBC インターフェースでデータ連携。

データ連携でお困りですか?

お問い合わせ

ODBC 標準はユビキタスをサポートし、セルフサービスBI を簡単にします。ODBC Driver を使ってAzure Analysis Services をTIBCO Spotfire にローディングします。





この記事では、CData ODBC Driver for Azure Analysis Services をTIBCO Spotfire で使う方法を説明します。データインポートウィザードを使ってのDSN(データソース名)に接続し、サンプルビジュアライゼーション上でビルドして簡単なダッシュボードを作成します。

  1. 接続プロパティの指定がまだの場合は、DSN (データソース名)で行います。Microsoft ODBC データソースアドミニストレーターを使ってODBC DSN を作成および設定できます。一般的な接続プロパティは以下のとおりです:

    • URL

    Microsoft ODBC データソースアドミニストレーターで必要なプロパティを設定する方法は、ヘルプドキュメントの「はじめに」をご参照ください。

    To connect to Azure Analysis Services, set the Url property to a valid server, for instance, asazure://southcentralus.asazure.windows.net/server, in addition to authenticating. Optionally, set Database to distinguish which Azure database on the server to connect to.

    Azure Analysis Services uses the OAuth authentication standard. OAuth requires the authenticating user to interact with Azure Analysis Services using the browser. You can connect without setting any connection properties for your user credentials. See the Help documentation for more information.

  2. [File]>[Add Data Tables]をクリックします。
  3. ライブデータを使いたい場合は、[Keep Data Table External]オプションをクリックします。このオプションは、データの変更をリアルタイムでダッシュボードに反映します。また、大量のデータを扱う場合に、ネットワークのロード回数を低減します。

    データをメモリにロードしてローカルで処理したい場合は、[Import Data Table]オプションをクリックします。このオプションは、オフラインでの使用、またはスローなネットワーク接続によりダッシュボードがインタラクティブでない場合に使用します。

  4. [Add]>[Database]をクリックします。
  5. [Data Source Type]メニューでODBC Provider を選択し[Configure]をクリックします。
  6. DSN を選択します。
  7. ダッシュボードに追加したいテーブルを選択します。この例ではCustomer を使います。SQL クエリも指定できます。ドライバーは標準SQL シンタックスをサポートしています。
  8. テーブルを追加すると[Recommended Visualizations]ウィザードが表示されます。テーブルを選択すると、Spotfire はカラムのデータ型を使ってnumber、time、category カラムを検出します。この例ではNumbers セクションでEducation を、Categories セクションでCountry を使用しています。

[Recommended Visualizations]ウィザードでいくつかビジュアライズしたら、ダッシュボードにその他の修正を加えられます。例えば、ページにフィルタを適用することで、高確率なopportunities にズームインできます。フィルタを追加するには、[Filter]ボタンをクリックします。各クエリで利用可能なフィルタは、[Filters]ペインに表示されます。