Tibco Spotfire から、ODBC 経由でGreenplum データに連携してビジュアライズ

Ready to get started?

Download for a free trial:

Download Now

Learn more:

Greenplum ODBC Driver

Pivotal Greenplum ODBC Driver で、ODBC 接続をサポートするあらゆるツール・アプリケーションからPivotal Greenplum データベースに連携が可能になります。

標準ODBC Driver インターフェースでPivotal Greenplum データベースをを仮想化してどこからでもアクセス可能に。



ODBC 標準はユビキタスをサポートし、セルフサービスBI を簡単にします。ODBC Driver を使ってGreenplum をTIBCO Spotfire にローディングします。



この記事では、CData ODBC Driver for Greenplum をTIBCO Spotfire で使う方法を説明します。データインポートウィザードを使ってのDSN(データソース名)に接続し、サンプルビジュアライゼーション上でビルドして簡単なダッシュボードを作成します。

  1. 接続プロパティの指定がまだの場合は、DSN (データソース名)で行います。Microsoft ODBC データソースアドミニストレーターを使ってODBC DSN を作成および設定できます。一般的な接続プロパティは以下のとおりです:

    • User
    • Password
    • Database
    • Server
    • Port

    Microsoft ODBC データソースアドミニストレーターで必要なプロパティを設定する方法は、ヘルプドキュメントの「はじめに」をご参照ください。

    Greenplum に接続するには、Server、Port (デフォルトポートは5432)、およびDatabase 接続プロパティを設定して、サーバーへの認証に使用するUser とPassword を設定します。Database プロパティが指定されていない場合、本製品はユーザーのデフォルトデータベース(ユーザーと同じ名前になります)に接続します。

  2. [File]>[Add Data Tables]をクリックします。
  3. ライブデータを使いたい場合は、[Keep Data Table External]オプションをクリックします。このオプションは、データの変更をリアルタイムでダッシュボードに反映します。また、大量のデータを扱う場合に、ネットワークのロード回数を低減します。

    データをメモリにロードしてローカルで処理したい場合は、[Import Data Table]オプションをクリックします。このオプションは、オフラインでの使用、またはスローなネットワーク接続によりダッシュボードがインタラクティブでない場合に使用します。

  4. [Add]>[Database]をクリックします。
  5. [Data Source Type]メニューでODBC Provider を選択し[Configure]をクリックします。
  6. DSN を選択します。
  7. ダッシュボードに追加したいテーブルを選択します。この例ではOrders を使います。SQL クエリも指定できます。ドライバーは標準SQL シンタックスをサポートしています。
  8. テーブルを追加すると[Recommended Visualizations]ウィザードが表示されます。テーブルを選択すると、Spotfire はカラムのデータ型を使ってnumber、time、category カラムを検出します。この例ではNumbers セクションでShipName を、Categories セクションでFreight を使用しています。

[Recommended Visualizations]ウィザードでいくつかビジュアライズしたら、ダッシュボードにその他の修正を加えられます。例えば、ページにフィルタを適用することで、高確率なopportunities にズームインできます。フィルタを追加するには、[Filter]ボタンをクリックします。各クエリで利用可能なフィルタは、[Filters]ペインに表示されます。