製品をチェック

Phoenix ODBC Driver の30日間無償トライアルをダウンロード

 ダウンロードはこちら

製品の詳細

Apache Phoenix アイコン Phoenix ODBC Driver 相談したい

Phoenix ODBC Driver を使って、ODBC 接続をサポートするあらゆるアプリケーション・ツールからApache Phoenix 経由でHBase にデータ連携。

Phoenix に標準ODBC Driver インターフェースを使ってRDB と同感覚でアクセスして、読み書き更新を実行。

Power View でのPhoenix データのインポートとビジュアライズ

Excel でPhoenix データを使ったデータビジュアライゼーションを作成します。

古川えりか
コンテンツスペシャリスト

最終更新日:2022-10-10

こんにちは!ドライバー周りのヘルプドキュメントを担当している古川です。

Excel に組み込まれているODBC サポートを使用して、Phoenix データを使用したPower View レポートを素早く作成できます。この記事では、Data リボンからアクセスできるData Connection Wizard を使用して、Phoenix をPower View レポートにインポートする方法を説明します。

CData ODBC Drivers とは?

CData ODBC Drivers は、以下のような特徴を持ったリアルタイムデータ連携ソリューションです。

  1. Phoenix をはじめとする、CRM、MA、会計ツールなど多様なカテゴリの270種類以上のSaaS / オンプレミスデータソースに対応
  2. 多様なアプリケーション、ツールにPhoenix データを連携
  3. ノーコードでの手軽な接続設定
  4. 標準 SQL での柔軟なデータ読み込み・書き込み

CData ODBC Driver では、1.データソースとしてPhoenix の接続を設定、2.Power View 側でODBC Driver との接続を設定、という2つのステップだけでデータソースに接続できます。以下に具体的な設定手順を説明します。

CData ODBC Drivers のインストールとPhoenix への接続設定

まずは、本記事右側のサイドバーからApachePhoenix ODBC Driver の無償トライアルをダウンロード・インストールしてください。30日間無償で、製品版の全機能が使用できます。

未指定の場合は、初めにODBC DSN で接続プロパティを指定します。ドライバーのインストールの最後にアドミニストレーターが開きます。Microsoft ODBC Data Source Administrator を使用して、ODBC DSN を作成および構成できます。

Phoenix Query Server 経由でApache Phoenix に接続します。デフォルトのポートと異なる場合は、Server とPort プロパティを設定してApache Phoenix に接続します。Servre プロパティは通常、Apache Phoenix をホストしているサーバーのホスト名またはIP アドレスです。

Apache Phoenix への認証

デフォルトでは、認証は使用されません(プレーン)。サーバーに認証が設定されている場合は、AuthScheme をNEGOTIATE に設定して、 必要な場合にはUser とPassword プロパティを設定して、Kerberos で認証します。

DSN を構成する際に、Max Rows プロパティを定めることも可能です。これによって返される行数が制限されるので、ビジュアライゼーション・レポートのデザイン時のパフォーマンスを向上させるのに役立ちます。

Data Connection Wizard で接続

以下のステップに従って、Excel のData Connection Wizard からDSN に接続します。

  1. [Data]タブで、[From Other Sources]->[From Data Connection Wizard]とクリックします。
  2. [Data Connection Wizard]で[ODBC DSN]オプションを選択します。
  3. リストから[ODBC DSN for ApachePhoenix]を選択します。
  4. 操作するテーブルを選択します。

    複数のテーブルをインポートする場合は、[Connect to a specific table]オプションの選択を解除します。データソースに接続したら、複数のテーブルを選択できます。[Finish]をクリックして[Data Connection Wizard]を閉じた後、[Select Table]ダイアログで[Enable selection of multiple tables]オプションを選択します。

  5. [Import Data]ダイアログで、データのインポート先を選択します。例えば、[Table]オプションと[Existing worksheet]オプションを選択します。次に、結果を出力するワークシートのセルをクリックします。
  6. [Insert]->[Power View]とクリックして新しいPower View レポートを作成します。

テーブルの作成

テーブルは、チャートやその他のデータの表現の開始点です。テーブルを作成するには、フィールドリストでカラムを選択します。テーブル名とカラム名をビューにドラッグアンドドロップすることも可能です。

A table with a filter applied.(Salesforce is shown.)

データのビジュアライゼーションを作成

[Design]タブで、テーブルをチャートやその他のビジュアライゼーションに変更できます。

The table of data represented as a stacked bar chart.(Salesforce is shown.)

Phoenix からPower View へのデータ連携には、ぜひCData ODBC Driver をご利用ください

このようにCData ODBC Drivers と併用することで、270を超えるSaaS、NoSQL データをコーディングなしで扱うことができます。30日の無償評価版が利用できますので、ぜひ自社で使っているクラウドサービスやNoSQL と合わせて活用してみてください。

CData ODBC Driver は日本のユーザー向けに、UI の日本語化、ドキュメントの日本語化、日本語でのテクニカルサポートを提供しています。

関連コンテンツ

トライアル・お問い合わせ

30日間無償トライアルで、CData のリアルタイムデータ連携をフルにお試しいただけます。記事や製品についてのご質問があればお気軽にお問い合わせください。