<br><b>Code</b>: rsb:print<br><b>Error</b>: Formatter [ extraconnectionprops ] failed in the evaluation of <p> [company_name] ODBC driver for [service] ?????[datasource] ???????????? ?????Cognos Report Studio ??????????????????????????????SQL ??????????????????????[service] ??????????SQL ??????????????????????? </p> <h2>??????????????????</h2> <p> ??????????[Cognos Administration]??????? [datasource] ???????????????Cognos BI ????????????????????????????????????????????:???[datasource] ???????? </p> <ol> <li> <p>??????????????????ODBC DSN (???????)??????Microsoft ODBC ????????????????????ODBC DSN ????????????? <p>64??????????Cognos ???????????32????ODBC ??????????????????????????????????????????????:</p><code>C:\Windows\sysWOW64\odbcad32.exe </code> <p> ?????????????????: </p> <p> [extraconnectionprops] </p> <p>Microsoft ODBC ??????????????????????????????????????????????????????????? </p> </li> <li> <p> [Cognos Administration]????????????????????[Data Source Connections]???????[ODBC]????????????????DSN ?????????????????????Click Retrieve Objects and choose the [company_name] [service] database object.</p> <img src="../articles/odbc-cognos-1.png" title="The DSN used to add the data source. (Salesforce is shown.)"/> </li> </ol> <h2>Data Visualizations ????????</h2> <p> ????[Source Explorer]??????????????????????????????Cognos Report Studio ?[datasource] ?????????????????????????????????????????????????????????? </p> <p> ????????????Cognos Report Studio ?SQL ?????????????????????????????????[service] API ???????????????????????[datasource] ?????????????API ??????? </p> <h2>?????????????????</h2> <p> [Source Explorer]?????????dimentions ????????????????????????????Cognos ???????????[datasource] ?????????????????Series dimension ??????????????????? </p> <p>???Cognos ??measure dimesion ??????????????????????????????????????????????????????????????[Data Items]???. The error was: The value of the attribute could not be accessed: The attribute does not exist.<br><b>URL</b>: /jp/kb/tech/sql-odbc-cognos.rst