Alteryx DesignerにてSage US Dataを、データプレパレーション・データブレンディング・分析

セルフサービスデータアナリティクスのためのSage US data へのライブ接続のWorkflowを構築

Sage US 用のCData ODBCドライバは、ODBC標準のSage USからのライブデータへのアクセスを可能にし、使い慣れたSQLクエリで多種多様なBI、レポート、ETLツールでSage US dataを扱うことができます 。 この記事では、セルフサービスBI、データプレパレーション、データブレンディング、アドバンスドアナリティクスを得意とするAlteryx DesignerでODBC接続を使用してSage US dataに接続して利用する方法を示します。

Sage US Dataへの接続

  1. まだ行っていない場合は、データソース名(DSN)に必要な接続プロパティの値を入力します。 組み込みのMicrosoft ODBCデータソースアドミニストレーターを使用してDSNを構成できます。 これは、ドライバのインストールじの最後のステップでも可能です。 Microsoft ODBCデータソースアドミニストレータを使用してDSNを作成および設定する方法については、ヘルプドキュメントの「はじめに」の章を参照してください。

    The Application Id and Company Name connection string options are required to connect to Sage as a data source. You can obtain an Application Id by contacting Sage directly to request access to the Sage 50 SDK.

    Sage must be installed on the machine. The Sage.Peachtree.API.dll and Sage.Peachtree.API.Resolver.dll assemblies are required. These assemblies are installed with Sage in C:\Program Files\Sage\Peachtree\API\. Additionally, the Sage SDK requires .NET Framework 4.0 and is only compatible with 32-bit applications. To use the Sage SDK in Visual Studio, set the Platform Target property to "x86" in Project -> Properties -> Build.

    You must authorize the application to access company data: To authorize your application to access Sage, restart the Sage application, open the company you want to access, and connect with your application. You will then be prompted to set access permissions for the application in the resulting dialog.

    While the compiled executable will require authorization only once, during development you may need to follow this process to reauthorize a new build. To avoid restarting the Sage application when developing with Visual Studio, click Build -> Configuration Manager and uncheck "Build" for your project.

  2. Alteryx Designer を開いて新しいワークフローを作成します。
  3. 新しいInput Data ToolをWorkflowにドラッグ&ドロップします。
  4. 新しい input data toolをクリックして、File or Database下の「Database Connection -> New ODBC Connection...」を選択します。
  5. Alteryx用に定義下設定済みDSNを選択します。
  6. 開かれたウィザードの中で、クエリーに含めたいフィールドを選択します。
  7. Sage US data内のデータを要件にあった内容で正確に取得しているかを確認する場合には、SQLEditorを開き、クエリーを手動で変更することができます。

クエリー定義で、Alteryx Designer内でSage US dataへの接続の準備ができました。

Sage US Dataに対するセルフサービス分析の実行

これで、Sage US dataのデータプレパレーション、ブレんディング、分析を行うワークフローを作成する準備が整いました。 以下の例では、データを整理して参照します。

  1. workflowにデータクレンジングツールを追加し、Nullテキストフィールドをブランクに置き換え、ヌル数値フィールドを0に置き換えるには、NULLを置き換えるのボックスをオンにします。また、不要な文字を削除するにチェックを入れて先頭と末尾の空白を削除することもできます。
  2. workflowにbrowse data toolを追加します。
  3. run the workflow (CTRL+R)をクリック。
  4. 結果ビューにてクレンジングされたSage US dataデータを確認します。
 
 
ダウンロード