Visio Shapes とBasecamp Data を連携

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

Basecamp ODBC Driver

Basecamp ODBC Driver は、ODBC 接続をサポートするさまざまなアプリケーションからBasecamp のリアルタイムデータ連携を実現するパワフルなツールです。

RDB にアクセスするときと同感覚でBasecamp にアクセスし、標準ODBC Driver インターフェースを通じて読み出し、書き込み、更新が可能に。



Visio master shapes での変更を自動的にBasecamp data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Basecamp. The driver surfaces Basecamp data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Basecamp data.

Connect to Basecamp as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Basecamp はBasic 認証もしくはOAuth 2.0 認証を使います。Basic 認証を使用するには、Basecamp へのログインに使用するuser およびpassword が必要です。OAuth 2.0 を使用して認証するには、Basecamp にアプリを登録してOAuthClientId、OAuthClientSecret、およびCallbackURL 接続プロパティを取得する必要があります。

詳しくは、ヘルプドキュメントの「はじめに」セクションを参照してください。

さらに、AccountId 接続プロパティを設定する必要があります。これはBasecamp にログイン後にURL で確認できます。

Connect Basecamp Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Basecamp, select the table you want to import, and finish the wizard. This article uses Projects as an example.

Link Basecamp Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Basecamp entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Projects as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Basecamp entities onto the drawing page and add association lines back to the main topic, Projects. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Projects entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Basecamp data.