Power View でのGoogle Analytics データのインポートとビジュアライズ

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

Google Analytics ODBC Driver

Google アナリティクスODBC ドライバーは、ODBC 接続をサポートする任意のアプリケーションからGoogle アナリティクスのリアルタイムデータに直接接続できるパワフルなツールです。標準のODBC ドライバーインタフェースを使用して、データベースのようにGoogle アナリティクスデータにアクセスし、すべての種類のリアルタイムなサイトトラフィックおよび分析データにアクセスできます。



Excel でGoogle Analytics データを使ったデータビジュアライゼーションを作成します。

Excel に組み込まれているODBC サポートを使用して、Google Analytics データを使用したPower View レポートを素早く作成できます。この記事では、Data リボンからアクセスできるData Connection Wizard を使用して、Google Analytics をPower View レポートにインポートする方法を説明します。

ODBC Data Source としてGoogle Analytics に接続

未指定の場合は、初めにODBC DSN (data source name) で接続プロパティを指定します。ドライバーのインストールの最後にアドミニストレーターが開きます。Microsoft ODBC Data Source Administrator を使用して、ODBC DSN を作成および構成できます。

OAuth 認証標準を使用してGoogle Analytics に接続します。ユーザーアカウントまたはサービスアカウントで認証できます。組織全体のアクセススコープを本製品に許可するには、サービスアカウントが必要です。下記で説明するとおり、本製品はこれらの認証フローをサポートします。

ユーザー資格情報の接続プロパティを設定せずに接続できます。次を設定して、接続してください。 Profile:接続するGoogle アナリティクスのプロファイル、またはビューに設定。この値はProfiles テーブルから取得できます。指定しない場合は、初めに返されたプロファイルが使われます。接続すると、本製品はデフォルトブラウザでOAuth エンドポイントを開きます。ログインして、アプリケーションにアクセス許可を与えます。本製品がOAuth プロセスを完了します。他のOAuth 認証フローについては、ヘルプドキュメントの「OAuth 認証の使用」を参照してください。

DSN を構成する際に、Max Rows プロパティを定めることも可能です。これによって返される行数が制限されるので、ビジュアライゼーション・レポートのデザイン時のパフォーマンスを向上させるのに役立ちます。

Data Connection Wizard で接続

以下のステップに従って、Excel のData Connection Wizard からDSN に接続します。

  1. [Data]タブで、[From Other Sources]->[From Data Connection Wizard]とクリックします。
  2. [Data Connection Wizard]で[ODBC DSN]オプションを選択します。
  3. リストから[ODBC DSN for Google Analytics]を選択します。
  4. 操作するテーブルを選択します。

    複数のテーブルをインポートする場合は、[Connect to a specific table]オプションの選択を解除します。データソースに接続したら、複数のテーブルを選択できます。[Finish]をクリックして[Data Connection Wizard]を閉じた後、[Select Table]ダイアログで[Enable selection of multiple tables]オプションを選択します。

  5. [Import Data]ダイアログで、データのインポート先を選択します。例えば、[Table]オプションと[Existing worksheet]オプションを選択します。次に、結果を出力するワークシートのセルをクリックします。
  6. [Insert]->[Power View]とクリックして新しいPower View レポートを作成します。

テーブルの作成

テーブルは、チャートやその他のデータの表現の開始点です。テーブルを作成するには、フィールドリストでカラムを選択します。テーブル名とカラム名をビューにドラッグアンドドロップすることも可能です。

データのビジュアライゼーションを作成

[Design]タブで、テーブルをチャートやその他のビジュアライゼーションに変更できます。