Visio Shapes とGMO MakeShop Data を連携

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

GMO MakeShop ODBC Driver

GMO MakeShop ODBC ドライバーは、ODBC 接続をサポートする任意のアプリケーションからライブなGMO MakeShop データに直接接続できる強力なツールです。標準のODBC ドライバーインタフェースを使用して、データベースのようにGMO MakeShop にアクセスし、在庫、商品、受注などの読み出し、書き込み、および更新を実行できます。



Visio master shapes での変更を自動的にGMO MakeShop data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for GMO MakeShop. The driver surfaces GMO MakeShop data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to GMO MakeShop data.

Connect to GMO MakeShop as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

GMO MakeShop に接続するには、MembersAccessCode、OrdersAccessCode、ProductsAccessCode、およびShopId が必要です。

GMO MakeShop へのアクセスの設定

MembersAccessCode、OrdersAccessCode、ProductsAccessCode、およびShopId を取得するには、以下の手順に従ってください。

  • GMO MakeShop には各API のAccessCode が必要です。
  • GMO MakeShop Store Manager にログインし、メニューの「ショップ作成」をクリックします。
  • 左ナビゲーションメニューの「外部システム連携」から任意の連携対象設定ををクリックします(メニューに表示されない場合は別途GMO MakeShop にご確認ください)。
  • 商品データ連携設定の場合:認証コードの「発行」ボタンをクリックし、ProductsAccessCode を取得します。
  • 注文データ連携設定の場合:最初に「注文情報参照」と「注文情報変更」の設定を選択します。選択後、認証コードの「発行」ボタンをクリックし、OrdersAccessCode を取得します。
  • 会員データ連携設定の場合:最初に「会員情報の(参照・登録・変更・削除)」の設定を選択します。選択後、認証コードの「発行」ボタンをクリックし、MembersAccessCode を取得します。
  • 会員認証連携設定の場合:認証コードの「発行」ボタンをクリックし、ProductsAccessCode を取得します。

GMO MakeShop アカウントの認証

次の接続プロパティを設定して接続します。

  • ShopId:接続先のGMO MakeShop Store ID を設定。GMO MakeShop Store ID はログイン用の ID と同じです。
  • OrdersAccessCode:「注文データ連携設定」から取得した「認証コード」を設定。このプロパティは Orders テーブルにアクセスする場合に必要です。
  • ProductsAccessCode:「商品データ連携設定」から取得した「認証コード」を設定。このプロパティは Products テーブルにアクセスする場合に必要です。
  • MembersAccessCode:「会員データ連携設定」から取得した「認証コード」を設定。このプロパティは Members テーブルにアクセスする場合に必要です。
  • MemberAuthenticationCode:「会員認証連携設定」から取得した「認証コード」を設定。このプロパティは MemberAuthenticationConfirm を実行する場合に必要です。
  • Password:GMO MakeShop Store Manager のログインユーザーのパスワードを指定。このプロパティは ProductCategoryRegistrationOrModification,ProductMemberGroupPriceRegistrationOrModification,ProductOptionRegistrationOrModification,ProductRegistrationOrModification を実行する場合に必要です。

Connect GMO MakeShop Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for GMO MakeShop, select the table you want to import, and finish the wizard. This article uses Products as an example.

Link GMO MakeShop Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link GMO MakeShop entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Products as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other GMO MakeShop entities onto the drawing page and add association lines back to the main topic, Products. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Products entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external GMO MakeShop data.