Ready to get started?

Learn more about the CData JDBC Driver for Sage 50 UK or download a free trial:

Download Now

Pentaho Report Designer にSage 50 UK Data を繋いでみた

Pentaho BI ツールでSage 50 UK data のレポートを作成。



CData JDBC Driver for Sage 50 UK data はダッシュボードや帳票ツールからライブデータへのアクセスを可能にします。この記事では、Sage 50 UK data をJDBC データソースとして接続する方法と、Pentaho でSage 50 UK data を元に帳票を作成する方法を説明します。

接続と帳票の作成

  1. インストールディレクトリの[lib]サブフォルダ内のJAR ファイルをコピーし、Pentaho のディレクトリ内の\Report-Designer\lib\jdbc\ フォルダに配置します。
  2. \Report-Designer\ フォルダのreport-designer.bat ファイルを起動し、Report-Designer UI を開きます。
  3. 以下の手順でドライバーを新しいデータソースに設定します。[Data]>[Add Data Source]>[Advanced]>[JDBC (Custom)]とクリックし、新しいSage 50 UK 接続を作成します。ダイアログが表示されたら、次のように接続プロパティを設定します。

    • Custom Connection URL property:JDBC URL を入力。初めに以下を入力し jdbc:sage50uk: 次にセミコロン区切りで接続プロパティを入力します。

      Note: Only Sage 50 UK 2012 and above are supported.

      The User and Password properties, under the Connection section, must be set to valid Sage 50 UK user credentials. These values will be the same used to log in to the Sage 50 UK software.

      Additionally, the URL property, under the Connection section, will need to be set to the address of the company dataset desired. To obtain the address, do the following:

      1. If you have not already done so, open the Sage 50 UK software.
      2. Click Tools -> Internet Options.
      3. Select the SData Settings tab.
      4. Click the Details button next to Sage 50 Accounts. A window is displayed containing a list of company names along with the address to their corresponding datasets.
      5. Set the URL property to the value in the address field next to the company desired.

      以下は一般的なJDBC URL です:

      jdbc:sage50uk:URL=http://your-server:5493/sdata/accounts50/GCRM/your-address;User=Manager;
    • Custom Driver Class Name:cdata.jdbc.sage50uk.Sage50UKDriver と入力。
    • User Name:認証するユーザーネーム。
    • Password:認証するパスワード。

レポートに Sage 50 UK Data を追加

これで、Sage 50 UK data の帳票を作成する準備が整いました。

  1. 帳票にSage 50 UK データソースを追加します:[Data]>[Add Data Source]>[JDBC]をクリックし、データソースを選択します。

  2. クエリを設定します。この記事では次を使います:

    SELECT Name, FinanceBalance FROM TradingAccounts
  3. 帳票にチャートをドラッグし、ダブルクリックしてチャートを編集します。帳票を実行して、チャートを表示します。このクエリ結果を使って、TradingAccounts テーブルのシンプルなチャートを作成することができます。
  4. 帳票を実行して、チャートを見てみましょう。
 
 
ダウンロード