Tibco Spotfire から、ODBC 経由でWave Financial データに連携してビジュアライズ

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

Wave Financial ODBC Driver

Wave Financial ODBC Driver を使って、ODBC 接続をサポートするあらゆるアプリケーション・ツールからWave Financial にデータ連携。

Wave Financial データにデータベースと同感覚でアクセスして、Wave Financial のAccounts、Customers、Products など多様なデータに使い慣れたODBC インターフェースで双方向連携。



ODBC 標準はユビキタスをサポートし、セルフサービスBI を簡単にします。ODBC Driver を使ってWave Financial をTIBCO Spotfire にローディングします。



この記事では、CData ODBC Driver for Wave Financial をTIBCO Spotfire で使う方法を説明します。データインポートウィザードを使ってのDSN(データソース名)に接続し、サンプルビジュアライゼーション上でビルドして簡単なダッシュボードを作成します。

  1. 接続プロパティの指定がまだの場合は、DSN (データソース名)で行います。Microsoft ODBC データソースアドミニストレーターを使ってODBC DSN を作成および設定できます。一般的な接続プロパティは以下のとおりです:

    Microsoft ODBC データソースアドミニストレーターで必要なプロパティを設定する方法は、ヘルプドキュメントの「はじめに」をご参照ください。

    Connect using the API Token

    You can connect to Wave Financial by specifying the APIToken You can obtain an API Token using the following steps:

    1. Log in to your Wave account and navigate to "Manage Applications" in the left pane.
    2. Select the application that you would like to create a token for. You may need to create an application first.
    3. Click the "Create token" button to generate an APIToken.

    Connect using OAuth

    If you wish, you can connect using the embedded OAuth credentials. See the Help documentation for more information.

  2. [File]>[Add Data Tables]をクリックします。
  3. ライブデータを使いたい場合は、[Keep Data Table External]オプションをクリックします。このオプションは、データの変更をリアルタイムでダッシュボードに反映します。また、大量のデータを扱う場合に、ネットワークのロード回数を低減します。

    データをメモリにロードしてローカルで処理したい場合は、[Import Data Table]オプションをクリックします。このオプションは、オフラインでの使用、またはスローなネットワーク接続によりダッシュボードがインタラクティブでない場合に使用します。

  4. [Add]>[Database]をクリックします。
  5. [Data Source Type]メニューでODBC Provider を選択し[Configure]をクリックします。
  6. DSN を選択します。
  7. ダッシュボードに追加したいテーブルを選択します。この例ではInvoices を使います。SQL クエリも指定できます。ドライバーは標準SQL シンタックスをサポートしています。
  8. テーブルを追加すると[Recommended Visualizations]ウィザードが表示されます。テーブルを選択すると、Spotfire はカラムのデータ型を使ってnumber、time、category カラムを検出します。この例ではNumbers セクションでDueDate を、Categories セクションでId を使用しています。

[Recommended Visualizations]ウィザードでいくつかビジュアライズしたら、ダッシュボードにその他の修正を加えられます。例えば、ページにフィルタを適用することで、高確率なopportunities にズームインできます。フィルタを追加するには、[Filter]ボタンをクリックします。各クエリで利用可能なフィルタは、[Filters]ペインに表示されます。