今すぐお試しください!

製品の詳細CData ODBC Driver for Authorize.Net を確認して、無償評価版をダウンロード:

今すぐダウンロード

Visio Shapes とAuthorize.Net Data を連携

Visio master shapes での変更を自動的にAuthorize.Net data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Authorize.Net. The driver surfaces Authorize.Net data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Authorize.Net data.

Connect to Authorize.Net as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Merchant アカウントにログインして、[Security Settings]->[General Settings]ページから必要な接続値を取得できます。

  • UseSandbox:トランザクション処理に使われる&service; API。プロダクションアカウントを使用している場合、このプロパティを指定する必要はありません。開発アカウントを利用している場合には、このプロパティをTrue に設定します。
  • LoginID:ペイメントゲートウェイアカウントに紐づいているAPI ログインId。このプロパティは、利用者がウェブサイトトランザクションを送信する権限があるかを認証するために使われます。Merchant Interface にログインするときのログインId とは異なります。
  • TransactionKey:ペイメントゲートウェイアカウントに紐づいているトランザクションキー。このプロパティは、利用者がウェブサイトトランザクションを送信する権限があるかを認証するために使われます。

Connect Authorize.Net Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Authorize.Net, select the table you want to import, and finish the wizard. This article uses SettledBatchList as an example.

Link Authorize.Net Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Authorize.Net entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter SettledBatchList as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Authorize.Net entities onto the drawing page and add association lines back to the main topic, SettledBatchList. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other SettledBatchList entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Authorize.Net data.

 
 
ダウンロード