Visio Shapes とUSPS Data を連携

詳細情報をご希望ですか?

製品の詳細情報:

USPS 連携ソリューション


Visio master shapes での変更を自動的にUSPS data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for USPS. The driver surfaces USPS data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to USPS data.

Connect to USPS as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

USPS に認証するには、次の接続プロパティを設定してください。

  • PostageProvider:リクエストの処理に使用するポステージプロバイダです。利用可能なオプションはENDICIA とSTAMPS です。指定されていない場合、 デフォルトはENDICIA です。
  • UseSandbox:ライブまたはテストリクエストを、運用サーバーに送るかサンドボックスサーバーに送るかを制御します。 true に設定した場合、Password、AccountNumber、StampsUserId プロパティは無視されます。
  • StampsUserId:この値はStamps サーバーに認証してログインするために使用されます。この値は Endicia には使用されず、UseSandbox がtrue の場合はオプションです。
  • Password:この値はEndicia とStamps サーバーへのログインに使用されます。ポステージプロバイダがEndicia の場合、この値はポステージアカウントに紐づけられたパスフレーズになります。 UseSandbox がtrue の場合にはオプションです。
  • AccountNumber:郵送者のアカウント番号です。UseSandbox がtrue の場合にはオプションです。
  • PrintLabelLocation:このプロパティは、GenerateLabels またはGenerateReturnLabels ストアドプロシージャを使用する場合には必須です。 生成されたラベルが格納されているフォルダの場所を指定してください。

キャッシュデータベース

USPS から利用可能な有用なタスクには多くのデータを要求します。データの入力を簡単にして後日思い出せるようにするには、 キャッシュデータベースを使用してリクエストを行ってください。キャッシュの使用にはキャッシュ用の接続プロパティを設定してください。

  • CacheLocation:デフォルトのキャッシュプロバイダーで接続が設定される、キャッシュの場所へのパスです。例えば、C:/users/username/documents/uspscache

CacheLocation の代わりに、CacheConnectionCacheProvider を設定して デフォルト以外のプロバイダーを使用してキャッシュ接続を設定することもできます。

Connect USPS Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for USPS, select the table you want to import, and finish the wizard. This article uses Senders as an example.

Link USPS Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link USPS entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Senders as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other USPS entities onto the drawing page and add association lines back to the main topic, Senders. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Senders entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external USPS data.