今すぐお試しください!

製品の詳細CData ODBC Driver for EDGAR Online を確認して、無償評価版をダウンロード:

今すぐダウンロード

Visio Shapes とEDGAR Online Data を連携

Visio master shapes での変更を自動的にEDGAR Online data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for EDGAR Online. The driver surfaces EDGAR Online data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to EDGAR Online data.

Connect to EDGAR Online as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

  1. Navigate to https://developer.edgar-online.com/ and create an account.
  2. Register a new application and retrieve the AppKey. You should select one of the available Web APIs this application will use like HackPack, Insider Trades or Institutional Ownership.
    Note: HackPack is the most important Web API that an application can use since it supports a large number of endpoints. If you are getting the "Access Denied" error you must create a new app and select the correct Web API which supports the resource you are querying.
  3. After successfully creating a new app, you can access your keys through your "my account" area. Set the AppKey connection property value equal to the Key of your application.

Connect EDGAR Online Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for EDGAR Online, select the table you want to import, and finish the wizard. This article uses Subscriptions as an example.

Link EDGAR Online Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link EDGAR Online entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Subscriptions as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other EDGAR Online entities onto the drawing page and add association lines back to the main topic, Subscriptions. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Subscriptions entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external EDGAR Online data.

 
 
ダウンロード