今すぐお試しください!

製品の詳細CData ODBC Driver for HPCC を確認して、無償評価版をダウンロード:

今すぐダウンロード

Visio Shapes とHPCC Systems Data を連携

Visio master shapes での変更を自動的にHPCC Systems data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for HPCC Systems. The driver surfaces HPCC Systems data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to HPCC Systems data.

Connect to HPCC Systems as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

To connect, set the following connection properties: Set URL to the machine name or IP address of the server and the port the server is running on, for example, https://server:port. The User and Password are required to authenticate to the HPCC Systems cluster specified in the URL. Note that LDAP authentication is not currently supported by our ODBC driver.

Set Version to the WsSQL Web server version. Note that if you have not already done so, you will need to install the WsSQL service on the HPCC Systems server. The WsSQL Web service is used to interact with the underlying HPCC Systems platform.

Set Cluster to the target cluster.

Connect HPCC Systems Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for HPCC Systems, select the table you want to import, and finish the wizard. This article uses hpcc::test::orders as an example.

Link HPCC Systems Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link HPCC Systems entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter hpcc::test::orders as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other HPCC Systems entities onto the drawing page and add association lines back to the main topic, hpcc::test::orders. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other hpcc::test::orders entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external HPCC Systems data.

 
 
ダウンロード