今すぐお試しください!

製品の詳細CData ODBC Driver for Confluence を確認して、無償評価版をダウンロード:

今すぐダウンロード

Visio Shapes とConfluence Data を連携

Visio master shapes での変更を自動的にConfluence data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Confluence. The driver surfaces Confluence data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Confluence data.

Connect to Confluence as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

API Token を取得する方法

API token は、アカウントへの認証に必須です。トークンの生成には、Atlassian アカウントでサービスにログインし、API tokens > Create API token に進みます。生成されたトークンが表示されます。

Confluence Cloud Account への接続

Cloud アカウントへの接続には、以下のプロパティを設定します(Password は、Server Instance への接続時のみ必要で、Cloud Account への接続には不要になりました。):

  • User: Confluence サーバーに認証するユーザー名。
  • APIToken: 認証するユーザーに紐付けられたAPI Token。
  • Url: JIRA エンドポイントのURL。例: https://yoursitename.atlassian.net

Confluence Server Instance への接続

Server instance への接続には以下を設定します:

  • User: Confluence Instance に接続するユーザー名。
  • Password: Confluence Instance に接続するユーザーのパスワード。
  • Url: JIRA エンドポイントのURL。例: https://yoursitename.atlassian.net

Connect Confluence Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Confluence, select the table you want to import, and finish the wizard. This article uses Pages as an example.

Link Confluence Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Confluence entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Pages as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Confluence entities onto the drawing page and add association lines back to the main topic, Pages. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Pages entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Confluence data.

 
 
ダウンロード