Tibco Spotfire から、ODBC 経由でSAP Business One DI データに連携してビジュアライズ

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

SAP Business One DI ODBC Driver

SAP Business One DI ODBC Driver を使って、ODBC 接続をサポートするあらゆるアプリケーション・ツールからSAP Business One DI にデータ連携。

SAP Business One DI データにデータベースと同感覚でアクセスして、SAP Business One DI のAccounts、Activities、Orders、Customers データに使い慣れたODBC インターフェースで双方向連携。



ODBC 標準はユビキタスをサポートし、セルフサービスBI を簡単にします。ODBC Driver を使ってSAP Business One DI をTIBCO Spotfire にローディングします。



この記事では、CData ODBC Driver for SAP Business One DI をTIBCO Spotfire で使う方法を説明します。データインポートウィザードを使ってのDSN(データソース名)に接続し、サンプルビジュアライゼーション上でビルドして簡単なダッシュボードを作成します。

  1. 接続プロパティの指定がまだの場合は、DSN (データソース名)で行います。Microsoft ODBC データソースアドミニストレーターを使ってODBC DSN を作成および設定できます。一般的な接続プロパティは以下のとおりです:

    • Server
    • DBServerType
    • CompanyDB
    • User
    • Password

    Microsoft ODBC データソースアドミニストレーターで必要なプロパティを設定する方法は、ヘルプドキュメントの「はじめに」をご参照ください。

    SAP Business One DI への接続には以下の接続プロパティを設定します:

    • DBServerType: 接続されているサーバーのタイプ。
    • Server: 接続先のSAP Business One サーバー。
    • CompanyDB: 接続先の会社。
    • User: LicenseServer に接続するときに使用されるユーザー名。
    • Password: LicenseServer に接続するときに使用されるパスワード。
    • LicenseServer (optional): Server と異なる場合。
    • UseTrusted (optional): TRUE に設定した場合、Windows 資格情報を介してSQL Server への接続を確立していることを示します。

  2. [File]>[Add Data Tables]をクリックします。
  3. ライブデータを使いたい場合は、[Keep Data Table External]オプションをクリックします。このオプションは、データの変更をリアルタイムでダッシュボードに反映します。また、大量のデータを扱う場合に、ネットワークのロード回数を低減します。

    データをメモリにロードしてローカルで処理したい場合は、[Import Data Table]オプションをクリックします。このオプションは、オフラインでの使用、またはスローなネットワーク接続によりダッシュボードがインタラクティブでない場合に使用します。

  4. [Add]>[Database]をクリックします。
  5. [Data Source Type]メニューでODBC Provider を選択し[Configure]をクリックします。
  6. DSN を選択します。
  7. ダッシュボードに追加したいテーブルを選択します。この例ではOACT を使います。SQL クエリも指定できます。ドライバーは標準SQL シンタックスをサポートしています。
  8. テーブルを追加すると[Recommended Visualizations]ウィザードが表示されます。テーブルを選択すると、Spotfire はカラムのデータ型を使ってnumber、time、category カラムを検出します。この例ではNumbers セクションでAcctName を、Categories セクションでAcctCode を使用しています。

[Recommended Visualizations]ウィザードでいくつかビジュアライズしたら、ダッシュボードにその他の修正を加えられます。例えば、ページにフィルタを適用することで、高確率なopportunities にズームインできます。フィルタを追加するには、[Filter]ボタンをクリックします。各クエリで利用可能なフィルタは、[Filters]ペインに表示されます。