Ready to get started?

Download a free trial of the ADP ODBC Driver to get started:

 Download Now

Learn more:

ADP Icon ADP ODBC Driver

The ADP ODBC Driver is a powerful tool that allows you to connect with live data from ADP, directly from any applications that support ODBC connectivity.

Access ADP data like you would a database - read, write, and update ADP FALSE, etc. through a standard ODBC Driver interface.

Link Visio Shapes to ADP Data



Automatically update ADP data with the changes you make to Visio master shapes.

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for ADP. The driver surfaces ADP data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to ADP data.

Connect to ADP as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Connect to ADP by specifying the following properties:

  • SSLClientCert: Set this to the certificate provided during registration.
  • SSLClientCertPassword: Set this to the password of the certificate.
  • UseUAT: The connector makes requests to the production environment by default. If using a developer account, set UseUAT = true.
  • RowScanDepth: The maximum number of rows to scan for the custom fields columns available in the table. The default value will be set to 100. Setting a high value may decrease performance.

The connector uses OAuth to authenticate with ADP. OAuth requires the authenticating user to interact with ADP using the browser. For more information, refer to the OAuth section in the Help documentation.

Connect ADP Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for ADP, select the table you want to import, and finish the wizard. This article uses Workers as an example.

Link ADP Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link ADP entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Workers as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other ADP entities onto the drawing page and add association lines back to the main topic, Workers. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Workers entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external ADP data.