Import and Visualize Airtable Data in Power View

Ready to get started?

Download for a free trial:

Download Now

Learn more:

Airtable ODBC Driver

The Airtable ODBC Driver is a powerful tool that allows you to connect with live data from Airtable, directly from any applications that support ODBC connectivity.

Access Airtable data like you would a database - read, write, and update Airtable Tables, etc. through a standard ODBC Driver interface.



Create data visualizations based on Airtable data in Excel.

You can use the built-in ODBC support in Excel to rapidly create Power View reports featuring Airtable data. This article shows how to use the Data Connection Wizard, accessible from the Data ribbon, to import Airtable data into a Power View report.

Connect to Airtable as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

APIKey, BaseId and TableNames parameters are required to connect to Airtable. ViewNames is an optional parameter where views of the tables may be specified.

  • APIKey : API Key of your account. To obtain this value, after logging in go to Account. In API section click Generate API key.
  • BaseId : Id of your base. To obtain this value, it is in the same section as the APIKey. Click on Airtable API, or navigate to https://airtable.com/api and select a base. In the introduction section you can find "The ID of this base is appxxN2ftedc0nEG7."
  • TableNames : A comma separated list of table names for the selected base. These are the same names of tables as found in the UI.
  • ViewNames : A comma separated list of views in the format of (table.view) names. These are the same names of the views as found in the UI.

When you configure the DSN, you may also want to set the Max Rows connection property. This will limit the number of rows returned, which is especially helpful for improving performance when designing reports and visualizations.

Connect with the Data Connection Wizard

Follow the steps below to connect to the DSN from the Data Connection Wizard in Excel.

  1. On the Data tab, click From Other Sources -> From Data Connection Wizard.
  2. In the Data Connection Wizard, select the ODBC DSN option.
  3. Select the ODBC DSN for Airtable from the list.
  4. Select the tables you want to work with.

    If you want to import multiple tables, deselect the "Connect to a specific table" option. After you connect to the data source, you can select multiple tables: After you click Finish to close the Data Connection Wizard, select the "Enable selection of multiple tables" option in the Select Table dialog.

  5. In the Import Data dialog, select the destination for your data. For example, select the Table option and the Existing worksheet option. Then click the cell in your worksheet where results should be output.
  6. Click Insert -> Power View to create a new Power View report.

Create a Table

Tables are the starting point for charts and other representations of your data. To create a table, select a column in the field list. You can also drag and drop table names and column names onto the view.

Create Data Visualizations

On the Design tab, you can change tables into charts and other visualizations.