Ready to get started?

Download a free trial of the Azure DevOps ODBC Driver to get started:

 Download Now

Learn more:

Azure DevOps Icon Azure DevOps ODBC Driver

The Azure DevOps ODBC Driver is a powerful tool that allows you to connect with live data from Azure DevOps, directly from any applications that support ODBC connectivity.

Access Azure DevOps data like you would a database - read, write, and update Azure DevOps Accounts, Approvals, Builds, Tests, etc. through a standard ODBC Driver interface.

Visualize Azure DevOps Data in TIBCO Spotfire through ODBC



The ODBC standard has ubiquitous support and makes self-service business intelligence easy. Use the ODBC Driver to load Azure DevOps data into TIBCO Spotfire.

This article walks you through using the CData ODBC Driver for Azure DevOps in TIBCO Spotfire. You will use the data import wizard to connect to a DSN (data source name) for Salesforce and build on the sample visualizations to create a simple dashboard.

Connect to Azure DevOps as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

You can connect to your Azure DevOps account by providing the Organization and PersonalAccessToken.

Obtaining a Personal Access Token

A PersonalAccessToken is necessary for account authentication.

To generate one, log in to your Azure DevOps Organization account and navigate to Profile -> Personal Access Tokens -> New Token. The generated token will be displayed.

If you wish to authenticate to Azure DevOps using OAuth refer to the online Help documentation for an authentication guide.

When you configure the DSN, you may also want to set the Max Rows connection property. This will limit the number of rows returned, which is especially helpful for improving performance when designing reports and visualizations.

Create Visualizations of Azure DevOps Tables

Follow the steps below to connect to the DSN and create real-time data visualizations:

  1. Click File -> Add Data Tables.
  2. Click Add -> Database.
  3. In the Data Source Type menu, select ODBC Provider and click Configure.
  4. Select the DSN.
  5. Select the tables that you want to add to the dashboard. This example uses Builds. You can also specify an SQL query. The driver supports the standard SQL syntax.
  6. If you want to work with the live data, click the Keep Data Table External option. This option enables your dashboards to reflect changes to the data in real time.

    If you want to load the data into memory and process the data locally, click the Import Data Table option. This option is better for offline use or if a slow network connection is making your dashboard less interactive.

  7. After adding tables, the Recommended Visualizations wizard is displayed. When you select a table, Spotfire uses the column data types to detect number, time, and category columns. This example uses BuildNumber in the Numbers section and Id in the Categories section.

After adding several visualizations in the Recommended Visualizations wizard, you can make other modifications to the dashboard. For example, you can zoom in on high probability opportunities by applying a filter on the page. To add a filter, click the Filter button. The available filters for each query are displayed in the Filters pane.