Import and Visualize Bullhorn CRM Data in Power View

Ready to get started?

Download for a free trial:

Download Now

Learn more:

Bullhorn CRM ODBC Driver

The Bullhorn CRM ODBC Driver is a powerful tool that allows you to connect with live data from Bullhorn CRM, directly from any applications that support ODBC connectivity.

Access Bullhorn CRM data like you would a database - read, write, and update Bullhorn CRM Candidates, Resumes, Searches, etc. through a standard ODBC Driver interface.



Create data visualizations based on Bullhorn CRM data in Excel.

You can use the built-in ODBC support in Excel to rapidly create Power View reports featuring Bullhorn CRM data. This article shows how to use the Data Connection Wizard, accessible from the Data ribbon, to import Bullhorn CRM data into a Power View report.

Connect to Bullhorn CRM as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Begin by providing your Bullhorn CRM account credentials in the following:

If you are uncertain about your data center code, codes like CLS2, CLS21, etc. are cluster IDs that are contained in a user's browser URL (address bar) once they are logged in.

Example: https://cls21.bullhornstaffing.com/BullhornSTAFFING/MainFrame.jsp?#no-ba... indicates that the logged in user is on CLS21.

Authenticating with OAuth

Bullhorn CRM uses the OAuth 2.0 authentication standard. To authenticate using OAuth, create and configure a custom OAuth app. See the Help documentation for more information.

When you configure the DSN, you may also want to set the Max Rows connection property. This will limit the number of rows returned, which is especially helpful for improving performance when designing reports and visualizations.

Connect with the Data Connection Wizard

Follow the steps below to connect to the DSN from the Data Connection Wizard in Excel.

  1. On the Data tab, click From Other Sources -> From Data Connection Wizard.
  2. In the Data Connection Wizard, select the ODBC DSN option.
  3. Select the ODBC DSN for Bullhorn CRM from the list.
  4. Select the tables you want to work with.

    If you want to import multiple tables, deselect the "Connect to a specific table" option. After you connect to the data source, you can select multiple tables: After you click Finish to close the Data Connection Wizard, select the "Enable selection of multiple tables" option in the Select Table dialog.

  5. In the Import Data dialog, select the destination for your data. For example, select the Table option and the Existing worksheet option. Then click the cell in your worksheet where results should be output.
  6. Click Insert -> Power View to create a new Power View report.

Create a Table

Tables are the starting point for charts and other representations of your data. To create a table, select a column in the field list. You can also drag and drop table names and column names onto the view.

Create Data Visualizations

On the Design tab, you can change tables into charts and other visualizations.