Ready to get started?

Learn more about the CData ODBC Driver for Dynamics GP or download a free trial:

Download Now

Link Visio Shapes to Dynamics GP Data

Automatically update Dynamics GP data with the changes you make to Visio master shapes.

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Dynamics GP. The driver surfaces Dynamics GP data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Dynamics GP data.

Connect to Dynamics GP as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

To authenticate set the User and Password connection properties.

To connect set the URL to the Web services endpoint; for example, http://{servername}:{port}/Dynamics/GPService. Additionally, set CompanyId; you can obtain this value in the company setup window: Click Tools -> Setup -> Company.

By default, data summaries are not returned to save performance. Set LookupIds to true to return details such as line items; however, note that entities must be retrieved one at a time.

Connect Dynamics GP Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Dynamics GP, select the table you want to import, and finish the wizard. This article uses SalesInvoice as an example.

Link Dynamics GP Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Dynamics GP entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter SalesInvoice as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Dynamics GP entities onto the drawing page and add association lines back to the main topic, SalesInvoice. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other SalesInvoice entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Dynamics GP data.