Ready to get started?

Learn more about the CData ODBC Driver for Excel Services or download a free trial:

Download Now

Link Visio Shapes to Excel Services Data

Automatically update Excel Services data with the changes you make to Visio master shapes.

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Excel Services. The driver surfaces Excel Services data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Excel Services data.

Connect to Excel Services as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

The URL, User, and Password properties, under the Authentication section, must be set to valid credentials for SharePoint Online, SharePoint 2010, or SharePoint 2013. Additionally, the Library property must be set to a valid SharePoint Document Library and the File property must be set to a valid .xlsx file in the indicated Library.

Connect Excel Services Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Excel Services, select the table you want to import, and finish the wizard. This article uses Account as an example.

Link Excel Services Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Excel Services entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Account as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Excel Services entities onto the drawing page and add association lines back to the main topic, Account. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Account entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Excel Services data.