Ready to get started?

Learn more about the CData ODBC Driver for Google Spreadsheets or download a free trial:

Download Now

Import and Visualize Google Sheets Data in Power View

Create data visualizations based on Google Sheets data in Excel.

You can use the built-in ODBC support in Excel to rapidly create Power View reports featuring Google Sheets data. This article shows how to use the Data Connection Wizard, accessible from the Data ribbon, to import Google Sheets data into a Power View report.

Connect to Google Sheets as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

You can connect to a spreadsheet by providing authentication to Google and then setting the Spreadsheet connection property to the name or feed link of the spreadsheet. If you want to view a list of information about the spreadsheets in your Google Drive, execute a query to the Spreadsheets view after you authenticate.

ClientLogin (username/password authentication) has been officially deprecated since April 20, 2012 and is now no longer available. Instead, use the OAuth 2.0 authentication standard. To access Google APIs on behalf on individual users, you can use the embedded credentials or you can register your own OAuth app.

OAuth also enables you to use a service account to connect on behalf of users in a Google Apps domain. To authenticate with a service account, you will need to register an application to obtain the OAuth JWT values.

See the Getting Started chapter in the help documentation to connect to Google Sheets from different types of accounts: Google accounts, Google Apps accounts, and accounts using two-step verification.

When you configure the DSN, you may also want to set the Max Rows connection property. This will limit the number of rows returned, which is especially helpful for improving performance when designing reports and visualizations.

Connect with the Data Connection Wizard

Follow the steps below to connect to the DSN from the Data Connection Wizard in Excel.

  1. On the Data tab, click From Other Sources -> From Data Connection Wizard.
  2. In the Data Connection Wizard, select the ODBC DSN option.
  3. Select the ODBC DSN for Google Sheets from the list.
  4. Select the tables you want to work with.

    If you want to import multiple tables, deselect the "Connect to a specific table" option. After you connect to the data source, you can select multiple tables: After you click Finish to close the Data Connection Wizard, select the "Enable selection of multiple tables" option in the Select Table dialog.

  5. In the Import Data dialog, select the destination for your data. For example, select the Table option and the Existing worksheet option. Then click the cell in your worksheet where results should be output.
  6. Click Insert -> Power View to create a new Power View report.

Create a Table

Tables are the starting point for charts and other representations of your data. To create a table, select a column in the field list. You can also drag and drop table names and column names onto the view.

Create Data Visualizations

On the Design tab, you can change tables into charts and other visualizations.