Ready to get started?

Learn more about the CData ODBC Driver for Google Spreadsheets or download a free trial:

Download Now

Link Visio Shapes to Google Sheets Data

Automatically update Google Sheets data with the changes you make to Visio master shapes.

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Google Sheets. The driver surfaces Google Sheets data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Google Sheets data.

Connect to Google Sheets as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

You can connect to a spreadsheet by providing authentication to Google and then setting the Spreadsheet connection property to the name or feed link of the spreadsheet. If you want to view a list of information about the spreadsheets in your Google Drive, execute a query to the Spreadsheets view after you authenticate.

ClientLogin (username/password authentication) has been officially deprecated since April 20, 2012 and is now no longer available. Instead, use the OAuth 2.0 authentication standard. To access Google APIs on behalf on individual users, you can use the embedded credentials or you can register your own OAuth app.

OAuth also enables you to use a service account to connect on behalf of users in a Google Apps domain. To authenticate with a service account, you will need to register an application to obtain the OAuth JWT values.

See the Getting Started chapter in the help documentation to connect to Google Sheets from different types of accounts: Google accounts, Google Apps accounts, and accounts using two-step verification.

Connect Google Sheets Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Google Sheets, select the table you want to import, and finish the wizard. This article uses Orders as an example.

Link Google Sheets Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Google Sheets entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Orders as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Google Sheets entities onto the drawing page and add association lines back to the main topic, Orders. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Orders entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Google Sheets data.