Ready to get started?

Learn more about the CData Excel Add-In for MS Project or download a free trial:

Download Now

Transfer Data from Excel to Microsoft Project

This article explains how to transfer data from Excel to Microsoft Project using the Excel Add-In for Microsoft Project.

The CData Excel Add-In for Microsoft Project enables you to edit and save Microsoft Project data directly from Excel. This article explains how to transfer data from Excel to Microsoft Project. This technique is useful if you want to work on Microsoft Project data in Excel and update changes, or if you have a whole spreadsheet you want to import into Microsoft Project. In this example, you will use the Projects table; however, the same process will work for any table that can be retrieved by the CData Excel Add-In.

Establish a Connection

If you have not already done so, create a new Microsoft Project connection by clicking From Microsoft Project on the ribbon.

The User and Password properties, under the Authentication section, must be set to valid Microsoft Project user credentials. In addition, you will need to specify a URL to a valid Microsoft Project server organization root or Microsoft Project services file.

Retrieve Data from Microsoft Project

To insert data into Microsoft Project, you will first need to retrieve data from the Microsoft Project table you want to add to. This links the Excel spreadsheet to the Microsoft Project table selected: After you retrieve data, any changes you make to the data are highlighted in red.

  1. Click the From Microsoft Project button on the CData ribbon. The Data Selection wizard is displayed.
  2. In the Table or View menu, select the Projects table.
  3. In the Maximum Rows menu, select the number of rows you want to retrieve. If you want to insert rows, you need to retrieve only one row. The Query box will then display the SQL query that corresponds to your request.
  4. In the Sheet Name box, enter the name for the sheet that will be populated. By default the add-in will create a new sheet with the name of the table.

Insert Rows to Microsoft Project

After retrieving data, you can add data from an existing spreadsheet in Excel.

  1. In a cell after the last row, enter a formula referencing the corresponding cell from the other spreadsheet; for example, =MyProjectsSheetInExcel!A1.
  2. After using a formula to reference the cells you want to add to Microsoft Project, select the cells that you are inserting data into and drag the formula down as far as needed. The referenced values you want to add will be displayed on the Projects sheet.
  3. Highlight the rows you want to insert and click the Insert Rows button.

As each row is inserted, the Id value will appear in the Id column and the row's text will change to black, indicating that the record has been inserted.