Visualize OneNote Data in TIBCO Spotfire through ODBC

Ready to get started?

Download for a free trial:

Download Now

Learn more:

OneNote ODBC Driver

The OneNote ODBC Driver is a powerful tool that allows you to connect with live Microsoft OneNote data, directly from any applications that support ODBC connectivity.

Access OneNote like you would a database - access Notebooks, Notes, Searches, Tags, etc. through a standard ODBC Driver interface.



The ODBC standard has ubiquitous support and makes self-service business intelligence easy. Use the ODBC Driver to load OneNote data into TIBCO Spotfire.

This article walks you through using the CData ODBC Driver for OneNote in TIBCO Spotfire. You will use the data import wizard to connect to a DSN (data source name) for Salesforce and build on the sample visualizations to create a simple dashboard.

Connect to OneNote as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

OneNote uses the OAuth authentication standard. To authenticate using OAuth, you will need to create an app to obtain the OAuthClientId, OAuthClientSecret, and CallbackURL connection properties. See the Help documentation for more information.

When you configure the DSN, you may also want to set the Max Rows connection property. This will limit the number of rows returned, which is especially helpful for improving performance when designing reports and visualizations.

Create Visualizations of OneNote Tables

Follow the steps below to connect to the DSN and create real-time data visualizations:

  1. Click File -> Add Data Tables.
  2. Click Add -> Database.
  3. In the Data Source Type menu, select ODBC Provider and click Configure.
  4. Select the DSN.
  5. Select the tables that you want to add to the dashboard. This example uses Notebooks. You can also specify an SQL query. The driver supports the standard SQL syntax.
  6. If you want to work with the live data, click the Keep Data Table External option. This option enables your dashboards to reflect changes to the data in real time.

    If you want to load the data into memory and process the data locally, click the Import Data Table option. This option is better for offline use or if a slow network connection is making your dashboard less interactive.

  7. After adding tables, the Recommended Visualizations wizard is displayed. When you select a table, Spotfire uses the column data types to detect number, time, and category columns. This example uses notebook_displayName in the Numbers section and Id in the Categories section.

After adding several visualizations in the Recommended Visualizations wizard, you can make other modifications to the dashboard. For example, you can zoom in on high probability opportunities by applying a filter on the page. To add a filter, click the Filter button. The available filters for each query are displayed in the Filters pane.