Ready to get started?

Download a free trial of the Salesforce Pardot ODBC Driver to get started:

 Download Now

Learn more:

Salesforce Pardot Icon Salesforce Pardot ODBC Driver

The Salesforce Pardot ODBC Driver is a powerful tool that allows you to connect with live data from Salesforce Pardot, directly from any applications that support ODBC connectivity.

Access Salesforce Pardot data like you would a database - read, write, and update Salesforce Pardot Emails, Lists, Opportunities, Users, etc. through a standard ODBC Driver interface.

Link Visio Shapes to Salesforce Pardot Data



Automatically update Salesforce Pardot data with the changes you make to Visio master shapes.

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Salesforce Pardot. The driver surfaces Salesforce Pardot data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Salesforce Pardot data.

Connect to Salesforce Pardot as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Salesforce Pardot supports connecting through API Version, Username, Password and User Key.

  • ApiVersion: The Salesforce Pardot API version which the provided account can access. Defaults to 4.
  • User: The Username of the Salesforce Pardot account.
  • Password: The Password of the Salesforce Pardot account.
  • UserKey: The unique User Key for the Salesforce Pardot account. This key does not expire.
  • IsDemoAccount (optional): Set to TRUE to connect to a demo account.

Accessing the Pardot User Key

The User Key of the current account may be accessed by going to Settings -> My Profile, under the API User Key row.

Connect Salesforce Pardot Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Salesforce Pardot, select the table you want to import, and finish the wizard. This article uses Prospects as an example.

Link Salesforce Pardot Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Salesforce Pardot entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Prospects as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Salesforce Pardot entities onto the drawing page and add association lines back to the main topic, Prospects. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Prospects entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Salesforce Pardot data.