Ready to get started?

Learn more about the CData ODBC Driver for Presto or download a free trial:

Download Now

Connect to and Query Presto Data in QlikView over ODBC

Create data visualizations with Presto data in QlikView.

The CData ODBC drivers expand your ability to work with data from more than 200 data sources. QlikView is a business discovery platform that provides self-service BI for all business users in an organization. This article outlines simple steps to connect to Presto data using the CData ODBC driver and create data visualizations in QlikView.

The CData ODBC drivers offer unmatched performance for interacting with live Presto data in QlikView due to optimized data processing built into the driver. When you issue complex SQL queries from QlikView to Presto, the driver pushes supported SQL operations, like filters and aggregations, directly to Presto and utilizes the embedded SQL engine to process unsupported operations (often SQL functions and JOIN operations) client-side. With built-in dynamic metadata querying, you can visualize and analyze Presto data using native QlikView data types.

Connect to Presto as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Set the Server and Port connection properties to connect, in addition to any authentication properties that may be required.

To enable TLS/SSL, set UseSSL to true.

Authenticating with LDAP

In order to authenticate with LDAP, set the following connection properties:

  • AuthScheme: Set this to LDAP.
  • User: The username being authenticated with in LDAP.
  • Password: The password associated with the User you are authenticating against LDAP with.

Authenticating with Kerberos

In order to authenticate with KERBEROS, set the following connection properties:

  • AuthScheme: Set this to KERBEROS.
  • KerberosKDC: The Kerberos Key Distribution Center (KDC) service used to authenticate the user.
  • KerberosRealm: The Kerberos Realm used to authenticate the user with.
  • KerberosSPN: The Service Principal Name for the Kerberos Domain Controller.
  • KerberosKeytabFile: The Keytab file containing your pairs of Kerberos principals and encrypted keys.
  • User: The user who is authenticating to Kerberos.
  • Password: The password used to authenticate to Kerberos.

When you configure the DSN, you may also want to set the Max Rows connection property. This will limit the number of rows returned, which is especially helpful for improving performance when designing reports and visualizations.

Populate a Chart with Presto Data

The steps below supply the results of an SQL query to a visualization in QlikView. In this article, you will create a bar chart with the query below:

SELECT FirstName, LastName FROM Customer WHERE Id = '123456789'
  1. Click File -> Edit Script (or click the Edit Script button in the Toolbar).
  2. On the Data tab, select ODBC in the Database menu and click Connect.
  3. Select the DSN (CData Presto Sys) in the resulting dialog. A command like the following is generated: ODBC CONNECT TO [CData Presto Sys];
  4. Enter the SQL query directly into the script with the SQL command (or click Select to build the query in the SELECT statement wizard). SQL SELECT FirstName, LastName FROM Customer WHERE Id = '123456789';

    Where possible, the SQL operations in the query, like filters and aggregations, will be pushed down to Presto, while any unsupported operations (which can include SQL functions and JOIN operations) will be managed client-side by the CData SQL engine embedded in the driver.

  5. Close the script editor and reload the document to execute the script.
  6. Click Tools -> Quick Chart Wizard. In the wizard, select the chart type. This example uses a bar chart. When building the chart, you have access to the fields from Presto, typed appropriately for QlikView, thanks to built-in dynamic metadata querying.
  7. When defining Dimensions, select FirstName in the First Dimension menu.
  8. When defining Expressions, click the summary function you want and select LastName in the menu.
  9. Finish the wizard to generate the chart. The CData ODBC Driver for Presto connects to live Presto data, so the chart can be refreshed to see real-time changes. Live connections are possible and effective, thanks to the high-performance data processing native to CData ODBC Drivers.