Ready to get started?

Learn more about the CData JDBC Driver for Sage 50 UK or download a free trial:

Download Now

Publish Reports with Sage 50 UK Data in Crystal Reports

Use the Report Wizard to design a report based on up-to-date Sage 50 UK data.

Crystal Reports has many options for offloading data processing to remote data; this enables real-time reporting. With the support for JDBC in Crystal Reports, the CData JDBC Driver for Sage 50 UK brings this capability to Crystal Reports. This article shows how to create a report on Sage 50 UK data that refreshes when you run the report.

Deploy the JDBC Driver

Install the CData JDBC Driver for Sage 50 UK by including the driver JAR in the Crystal Reports classpath: Add the full file path, including the .jar, to the paths in the ClassPath element, under the DataDriverCommonElement.

The CRConfig.xml is usually located at C:\Program Files (x86)\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\java — the path might be slightly different based on your installation. The driver JAR is located in the lib subfolder of the installation directory.

After you have added the JAR to the ClassPath, restart Crystal Reports.

Connect to Sage 50 UK Data

After deploying the JDBC Driver for Sage 50 UK, you can then use the Report Wizard to add Sage 50 UK data to a new report.

  1. Click File -> New -> Standard Report.
  2. Expand the JDBC node under Create New Connection and double-click Make a New Connection.
  3. In the wizard, enter the JDBC connection URL:

    jdbc:sage50uk:URL=http://your-server:5493/sdata/accounts50/GCRM/your-address;User=Manager;

    Note: Only Sage 50 UK 2012 and above are supported.

    The User and Password properties, under the Connection section, must be set to valid Sage 50 UK user credentials. These values will be the same used to log in to the Sage 50 UK software.

    Additionally, the URL property, under the Connection section, will need to be set to the address of the company dataset desired. To obtain the address, do the following:

    1. If you have not already done so, open the Sage 50 UK software.
    2. Click Tools -> Internet Options.
    3. Select the SData Settings tab.
    4. Click the Details button next to Sage 50 Accounts. A window is displayed containing a list of company names along with the address to their corresponding datasets.
    5. Set the URL property to the value in the address field next to the company desired.

    Built-in Connection String Designer

    For assistance in constructing the JDBC URL, use the connection string designer built into the Sage 50 UK JDBC Driver. Either double-click the JAR file or execute the jar file from the command-line.

    java -jar cdata.jdbc.sage50uk.jar

    Fill in the connection properties and copy the connection string to the clipboard.

    When you configure the JDBC URL, you may also want to set the Max Rows connection property. This will limit the number of rows returned, which is especially helpful for improving performance when designing reports and visualizations.

  4. Set the driver class name:

    cdata.jdbc.sage50uk.Sage50UKDriver
  5. Select the tables and fields needed in the report. This example uses the Name and FinanceBalance columns from the TradingAccounts table.

You can then configure grouping, sorting, and summaries. For example, this article groups on Name and summarizes on FinanceBalance. See the following section to use the aggregate and summary to create a chart.

Create a Chart

After selecting a column to group by, the Standard Report Creation Wizard presents the option to create a chart. Follow the steps below to create a chart that aggregates the values in the Name column.

  1. In the Standard Report Creation Wizard, select the Bar Chart option and select the column you grouped by, Name in this example, in the On Change Of menu.
  2. In the Show Summary menu, select the summary you created.
  3. Select filters and a template, as needed, to finish the wizard.

Preview the finished report to view the chart, populated with your data. If you want to filter out null values, use a SelectionFormula.

Working with Remote Data

To ensure that you see updates to volatile data, click File and clear the "Save Data with Report" option. As you interact with the report, for example, drilling down to hidden details, Crystal Reports executes SQL queries to retrieve the data needed to display the report. To reload data you have already retrieved, refresh or rerun the report.

You can offload processing onto the driver by hiding details elements and enabling server-side grouping. To do this, you will need to have selected a column to group on in the report creation wizard.

  1. Click File -> Report Options and select the Perform Grouping On Server option.
  2. Click Report -> Section Expert and select the Details section of your report. Select the Hide (Drill-Down OK) option.

When you preview your report with the hidden details, Crystal Reports executes a GROUP BY query. When you double-click a column in the chart to drill down to details, Crystal Reports executes a SELECT WHERE query that decreases load times by retrieving only the data needed, instead of the entire table.