Ready to get started?

Learn more about the CData ODBC Driver for Sage 50 UK or download a free trial:

Download Now

Create an SAP BusinessObjects Universe on the CData ODBC Driver for Sage 50 UK

Provide connectivity to Sage 50 UK data through an SAP BusinessObjects universe.

This article shows how to create and publish an SAP BusinessObjects universe on the CData ODBC Driver for Sage 50 UK. You will connect to Sage 50 UK data from the Information Design Tool as well as the Web Intelligence tool.

Connect to Sage 50 UK as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Note: Only Sage 50 UK 2012 and above are supported.

The User and Password properties, under the Connection section, must be set to valid Sage 50 UK user credentials. These values will be the same used to log in to the Sage 50 UK software.

Additionally, the URL property, under the Connection section, will need to be set to the address of the company dataset desired. To obtain the address, do the following:

  1. If you have not already done so, open the Sage 50 UK software.
  2. Click Tools -> Internet Options.
  3. Select the SData Settings tab.
  4. Click the Details button next to Sage 50 Accounts. A window is displayed containing a list of company names along with the address to their corresponding datasets.
  5. Set the URL property to the value in the address field next to the company desired.

When you configure the DSN, you may also want to set the Max Rows connection property. This will limit the number of rows returned, which is especially helpful for improving performance when designing reports and visualizations.

Create an ODBC Connection to Sage 50 UK Data

This section shows how to create a connection to the Sage 50 UK ODBC data source in the Information Design Tool. After you create a connection, you can analyze data or create a BusinessObjects universe.

  1. Right-click your project and click New -> New Relational Connection.

  2. In the wizard that is displayed, enter a name for the connection.
  3. Select Generic -> Generic ODBC datasource -> ODBC Drivers and select the DSN.

  4. Finish the wizard with the default values for connection pooling and custom parameters.

Analyze Sage 50 UK Data in the Information Design Tool

In the Information Design Tool, you can use both published and local ODBC connections to browse and query data.

  1. In the Local Projects view, double-click the connection (the .cnx file) to open the Sage 50 UK data source.

  2. On the Show Values tab, you can load table data and enter SQL queries. To view table data, expand the node for the table, right-click the table, and click Show Values. Values will be displayed in the Raw Data tab.

  3. On the Analysis tab, you can drag and drop columns onto the axes of a chart.

Publish the Local Connection

To publish the universe to the CMS, you additionally need to publish the connection.

  1. In the Local Projects view, right-click the connection and click Publish Connection to a Repository.

  2. Enter the host and port of the repository and connection credentials.

  3. Select the folder where the connection will be published.

  4. In the success dialog that results, click Yes to create a connection shortcut.

Create a Universe on the ODBC Driver for Sage 50 UK

You can follow the steps below to create a universe on the ODBC driver for Sage 50 UK. The universe in this example will be published to a repository, so it uses the published connection created in the previous step.

  1. In the Information Design Tool, click File->New Universe.

  2. Select your project.

  3. Select the option to create the universe on a relational data source.

  4. Select the shortcut to the published connection.

  5. Enter a name for the Data Foundation.

  6. Import tables and columns that you want to access as objects.

  7. Enter a name for the Business Layer.

Publish the Universe

You can follow the steps below to publish the universe to the CMS.

  1. In the Local Projects view, right-click the business layer and click Publish -> To a Repository.

  2. In the Publish Universe dialog, enter any integrity checks before importing.

  3. Select or create a folder on the repository where the universe will be published.

Query Sage 50 UK Data in Web Intelligence

You can use the published universe to connect to Sage 50 UK in Web Intelligence.

  1. Open Web Intelligence from the BusinessObjects launchpad and create a new document.

  2. Select the Universe option for the data source.

  3. Select the Sage 50 UK universe. This opens a Query Panel. Drag objects to the Result Objects pane to use them in the query.