Ready to get started?

Learn more about the CData ODBC Driver for SendGrid or download a free trial:

Download Now

Connect to and Query SendGrid Data in QlikView over ODBC

Create data visualizations with SendGrid data in QlikView.

The CData ODBC drivers expand your ability to work with data from more than 150 data sources. QlikView is a business discovery platform that provides self-service BI for all business users in an organization. This article outlines simple steps to connect to SendGrid data using the CData ODBC driver and create data visualizations in QlikView.

The CData ODBC drivers offer unmatched performance for interacting with live SendGrid data in QlikView due to optimized data processing built into the driver. When you issue complex SQL queries from QlikView to SendGrid, the driver pushes supported SQL operations, like filters and aggregations, directly to SendGrid and utilizes the embedded SQL engine to process unsupported operations (often SQL functions and JOIN operations) client-side. With built-in dynamic metadata querying, you can visualize and analyze SendGrid data using native QlikView data types.

Connect to SendGrid as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

To make use of all the available features, provide the User and Password connection properties.

To connect with limited features, you can set the APIKey connection property instead. See the "Getting Started" chapter of the help documentation for a guide to obtaining the API key.

When you configure the DSN, you may also want to set the Max Rows connection property. This will limit the number of rows returned, which is especially helpful for improving performance when designing reports and visualizations.

Populate a Chart with SendGrid Data

The steps below supply the results of an SQL query to a visualization in QlikView. In this article, you will create a bar chart with the query below:

SELECT Name, Clicks FROM AdvancedStats
  1. Click File -> Edit Script (or click the Edit Script button in the Toolbar).
  2. On the Data tab, select ODBC in the Database menu and click Connect.
  3. Select the DSN (CData SendGrid Sys) in the resulting dialog. A command like the following is generated: ODBC CONNECT TO [CData SendGrid Sys];
  4. Enter the SQL query directly into the script with the SQL command (or click Select to build the query in the SELECT statement wizard). SQL SELECT Name, Clicks FROM AdvancedStats;

    Where possible, the SQL operations in the query, like filters and aggregations, will be pushed down to SendGrid, while any unsupported operations (which can include SQL functions and JOIN operations) will be managed client-side by the CData SQL engine embedded in the driver.

  5. Close the script editor and reload the document to execute the script.
  6. Click Tools -> Quick Chart Wizard. In the wizard, select the chart type. This example uses a bar chart. When building the chart, you have access to the fields from SendGrid, typed appropriately for QlikView, thanks to built-in dynamic metadata querying.
  7. When defining Dimensions, select Name in the First Dimension menu.
  8. When defining Expressions, click the summary function you want and select Clicks in the menu.
  9. Finish the wizard to generate the chart. The CData ODBC Driver for SendGrid connects to live SendGrid data, so the chart can be refreshed to see real-time changes. Live connections are possible and effective, thanks to the high-performance data processing native to CData ODBC Drivers.