Link Visio Shapes to Smartsheet Data

Ready to get started?

Download for a free trial:

Download Now

Learn more:

Smartsheet ODBC Driver

The Smartsheet ODBC Driver is a powerful tool that allows you to connect with live data from Smartsheet, directly from any applications that support ODBC connectivity.

Access Smartsheet Sheets, Contacts, Folders, Groups, Users, etc. through a standard ODBC Driver interface.



Automatically update Smartsheet data with the changes you make to Visio master shapes.

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Smartsheet. The driver surfaces Smartsheet data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Smartsheet data.

Connect to Smartsheet as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Smartsheet uses the OAuth authentication standard. To authenticate using OAuth, you will need to register an app to obtain the OAuthClientId, OAuthClientSecret, and CallbackURL connection properties.

However, for testing purposes you can instead use the Personal Access Token you get when you create an application; set this to the OAuthAccessToken connection property.

Connect Smartsheet Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Smartsheet, select the table you want to import, and finish the wizard. This article uses Sheet_Event_Plan_Budget as an example.

Link Smartsheet Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Smartsheet entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Sheet_Event_Plan_Budget as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Smartsheet entities onto the drawing page and add association lines back to the main topic, Sheet_Event_Plan_Budget. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Sheet_Event_Plan_Budget entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Smartsheet data.