Ready to get started?

Learn more about the CData ODBC Driver for Splunk or download a free trial:

Download Now

Link Visio Shapes to Splunk Data

Automatically update Splunk data with the changes you make to Visio master shapes.

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Splunk. The driver surfaces Splunk data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Splunk data.

Connect to Splunk as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

To authenticate requests, set the User, Password, and URL properties to valid Splunk credentials. The port on which the requests are made to Splunk is port 8089.

The data provider uses plain-text authentication by default, since the data provider attempts to negotiate TLS/SSL with the server.

If you need to manually configure TLS/SSL, see Getting Started -> Advanced Settings in the data provider help documentation.

Connect Splunk Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Splunk, select the table you want to import, and finish the wizard. This article uses DataModels as an example.

Link Splunk Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Splunk entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter DataModels as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Splunk entities onto the drawing page and add association lines back to the main topic, DataModels. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other DataModels entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Splunk data.