Connect to Square from Asprova with CData ODBC Driver for Square

Ready to get started?

Download for a free trial:

Download Now

Learn more:

Square ODBC Driver

The Square ODBC Driver is a powerful tool that allows you to connect with live data from Square, directly from any applications that support ODBC connectivity.

Access Square Transactions, Items, Subscriptions, etc. through a standard ODBC Driver interface.



This article shows how to connect faster to Square data from Asprova.

The CData ODBC Driver for Square enables you to access Square data from Asprova. In this article, you will import Square data into item data in Asprova as an example.

Asprova setting

  1. Click File -> Data I/O Settings.

  2. Double click the header of Item and open the Edit I/O dialog.

  3. Select "No" from the RDB transaction combo box and close the dialog.

Data driver setting

  1. Select "OLE DB" from combo box in "Data source" column.

  2. Click button in Folder/database column and open the Data Link Property dialog. Select "Microsoft OLE DB Provider for ODBC Drivers" from the list of data provider.

  3. Select the Connection tab. Check "Use data source name" and select "CData Square Source" from DSN combo box.

  4. Click the Test Connection button and make sure you see the message "Connection successful".

Schema setting

  1. Click the button in "External table name" column and open the Table List dialog. Make sure tables in Square are listed in the dialog.

  2. Click the button in "Field mapping" column and open the Item-Field Mapping dialog.

  3. Open the context menu in the space between tables and click Delete All. Link corresponding fields by dragging mouse.

  4. Click File > Import and data will be imported into Asprova.

Check data

Click Table View > Item. Be sure you can see the item data stored in Square.