Link Visio Shapes to Zendesk Data

Ready to get started?

Download for a free trial:

Download Now

Learn more:

Zendesk ODBC Driver

The Zendesk ODBC Driver is a powerful tool that allows you to connect with live Zendesk project management data, directly from any applications that support ODBC connectivity.

Access Zendesk like you would a database - read, write, and update Tickets, Groups, Users, Schedules, etc. through a standard ODBC Driver interface.



Automatically update Zendesk data with the changes you make to Visio master shapes.

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Zendesk. The driver surfaces Zendesk data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Zendesk data.

Connect to Zendesk as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Connecting to Zendesk

To connect, set the URL and provide authentication. The URL is your Zendesk Support URL: https://{subdomain}.zendesk.com.

Authenticating to Zendesk

You can authenticate using the Basic or OAuth methods.

Using Basic Authentication

To use Basic authentication, specify your email address and password or your email address and an API token. Set User to your email address and follow the steps below to provide the Password or ApiToken.

  • Enable password access in the Zendesk Support admin interface at Admin > Channels > API.
  • Manage API tokens in the Zendesk Support Admin interface at Admin > Channels > API. More than one token can be active at the same time. Deleting a token deactivates it permanently.

Using OAuth Authentication

See the Getting Started guide in the CData driver documentation for an authentication guide.

Connect Zendesk Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Zendesk, select the table you want to import, and finish the wizard. This article uses Tickets as an example.

Link Zendesk Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Zendesk entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Tickets as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Zendesk entities onto the drawing page and add association lines back to the main topic, Tickets. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Tickets entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Zendesk data.